GTX465 - no CUDA-capable device is detected Bring-up problems for new GTX465

I just received a new GeForce GTX 465 this morning. Got it installed and running nicely in my Gentoo machine running 2.6.36-gentoo-r6 & nvidia-drivers-260.19.36. After just a little messing around with xorg.conf (attached at the end) the card is looking nice. 20000FPS in glxgears default, 2000FPS glxgears running full screen at 1920x1080. Power consumption in my machine is down about 20 Watts from the ATI HD5770 that I had been using. So far so good.

Next I tried the little enum_gpu program from the CUDA By Example book. It’s not finding the new device:

mark@c2stable chapter03 nvcc -arch compute_20 enum_gpu.cu -o enum_gpu mark@c2stable chapter03 ./enum_gpu
no CUDA-capable device is detected in enum_gpu.cu at line 23

I tried it with and without the -arch stuff. Same results.

I had no problems with this program on an older machine using an older GeForce 9500GT where I started my work. I purchased this card specifically to continue with my CUDA learning but I’m sort of stuck at this point.

Anyone know of any steps I might need to go through to get CUDA working here?

Thanks,
Mark

c2stable ~ # cat /etc/X11/xorg.conf
Section “Files”
ModulePath “/usr/lib/xorg/modules”
FontPath “/usr/share/fonts/misc/”
FontPath “/usr/share/fonts/TTF/”
FontPath “/usr/share/fonts/OTF”
FontPath “/usr/share/fonts/Type1/”
FontPath “/usr/share/fonts/100dpi/”
FontPath “/usr/share/fonts/75dpi/”
EndSection

Section “Module”
Load “extmod”
Load “glx”

Load “dri”

EndSection

Section “DRI”
Mode 0666
EndSection

Section “InputDevice”
Identifier “Keyboard0”
Driver “kbd”
EndSection

Section “InputDevice”
Identifier “Mouse0”
Driver “mouse”
Option “Protocol” “auto”
Option “Device” “/dev/input/mice”
Option “ZAxisMapping” “4 5 6 7”
EndSection

Section “Extensions”
Option “Composite” “Enable”
EndSection

Section “Device”
Identifier “NVidia Inc. GTX465”
Driver “nvidia”
EndSection

Section “Monitor”
Identifier “Samsung2333”
VendorName “Samsung”
ModelName “2333”
Option “PreferredMode” “1920x1080”
HorizSync 30-81
VertRefresh 56-75
EndSection

Section “Screen”
Identifier “Screen0”
Device “Card0”
Monitor “Samsung2333”
DefaultDepth 24
SubSection “Display”
Viewport 0 0
Depth 24
Modes “1920x1080”
EndSubSection
EndSection

Section “ServerLayout”
Identifier “c2”
Screen 0 “Screen0” 0 0
InputDevice “Mouse0” “CorePointer”
InputDevice “Keyboard0” “CoreKeyboard”
EndSection

c2stable ~ #

Updating to the development driver solved the problem. Sorry for the noise.

  • Mark

mark@c2stable ~ $ eix -I nvidia-drivers
[I] x11-drivers/nvidia-drivers
Available versions: 96.43.16!s 96.43.18!s 96.43.19!s 173.14.25!s 173.14.27!s 173.14.28!s (~)190.53-r1!s 195.36.24!s 195.36.31!s (~)256.44!s (~)256.44-r1!s (~)256.52!s (~)256.53!s (~)256.53-r1!s[1] (~)260.19.21!s {M}(~)260.19.26!s 260.19.29!s (~)260.19.36!s {M}(~)270.18!s {acpi custom-cflags gtk kernel_linux multilib}
Installed versions: 270.18!s(12:38:53 01/31/11)(acpi kernel_linux multilib -custom-cflags -gtk)
Homepage: http://www.nvidia.com/
Description: NVIDIA X11 driver and GLX libraries

[1] “pentoo” /var/lib/layman/pentoo
mark@c2stable ~ $

mark@c2stable ~ $ /opt/cuda/sdk/C/bin/linux/release/deviceQuery
/opt/cuda/sdk/C/bin/linux/release/deviceQuery Starting…

CUDA Device Query (Runtime API) version (CUDART static linking)

There is 1 device supporting CUDA

Device 0: “GeForce GTX 465”
CUDA Driver Version: 4.0
CUDA Runtime Version: 3.20
CUDA Capability Major/Minor version number: 2.0
Total amount of global memory: 1072889856 bytes
Multiprocessors x Cores/MP = Cores: 11 (MP) x 32 (Cores/MP) = 352 (Cores)
Total amount of constant memory: 65536 bytes
Total amount of shared memory per block: 49152 bytes
Total number of registers available per block: 32768
Warp size: 32
Maximum number of threads per block: 1024
Maximum sizes of each dimension of a block: 1024 x 1024 x 64
Maximum sizes of each dimension of a grid: 65535 x 65535 x 65535
Maximum memory pitch: 2147483647 bytes
Texture alignment: 512 bytes
Clock rate: 1.25 GHz
Concurrent copy and execution: Yes
Run time limit on kernels: Yes
Integrated: No
Support host page-locked memory mapping: Yes
Compute mode: Default (multiple host threads can use this device simultaneously)
Concurrent kernel execution: Yes
Device has ECC support enabled: No
Device is using TCC driver mode: No

deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 4.0, CUDA Runtime Version = 3.20, NumDevs = 1, Device = GeForce GTX 465

PASSED

Press to Quit…

mark@c2stable ~ cd CODE/CUDA/CUDA_by_Example/chapter03 mark@c2stable ~/CODE/CUDA/CUDA_by_Example/chapter03 ./enum_gpu
— General Information for device 0 —
Name: GeForce GTX 465
Compute capability: 2.0
Clock rate: 1250000
Device copy overlap: Enabled
Kernel execution timeout : Enabled
— Memory Information for device 0 —
Total global mem: 1072889856
Total constant Mem: 65536
Max mem pitch: 2147483647
Texture Alignment: 512
— MP Information for device 0 —
Multiprocessor count: 11
Shared mem per mp: 49152
Registers per mp: 32768
Threads in warp: 32
Max threads per block: 1024
Max thread dimensions: (1024, 1024, 64)
Max grid dimensions: (65535, 65535, 65535)

mark@c2stable ~/CODE/CUDA/CUDA_by_Example/chapter03 $