Guide to Enabling MCP251x (MCP2515) on the TX2 (SPI CAN)

You said you were able to get it working on the Pi without using an interrupt. I haven’t tried that, but if that’s supported you may need to delete the interrupt-parent and interrupts line from your DTS so it isn’t trying to use that for the input.

At this point it would be helpful to have a logic analyzer or oscilloscope to see what the SPI is while the board is trying to probe the MCP2515.

Here’s the source too, you may be able to find what that specific error means:

Actually, I have tried what you said, with deleting the interrupt entries in the dts.

Result and error is same.
If I select chip 0, it says that it is already in use.

Can this guide be used for Jetson NX SPI CAN BUS on MCP2515?
What are the problems and differences ?

Mostly the same, especially the kernel compilation and configuration steps.

The device tree steps will have different addresses, e.g. spi0 will probably not be at address spi@3210000. You’ll need use dmesg to find the path of the DTS file your board uses and go from there.

Once you find the proper DTS and hardware addresses the can and clocks blocks should be the same.

Can any one attach dtbo for Jetson NX MCP2515?

What you need should be in the Jetson Download Center