gzip: unexpected end of file during installation on RHEL 6

I am trying to install the cuda toolkit on a Red Hat 6 Enterprise machine. I downloaded the cuda_5.0.35_linux_64_rhel6.x-1.run multiple times (and I even tried the 64 bit version for redhat 5, just for good measure). However, whenever I run anything other than just --help I get this error:

gzip: stdin: unexpected end of file
Extraction failed.
Signal caught, cleaning up

Here some output in case this helps:

The command I used:
sudo sh ./cuda_5.0.35_linux_64_rhel6.x-1.run

ls cuda*
-rwxr-x–x. 1 xyz syst 469762048 Oct 23 2012 cuda_5.0.35_linux_64_rhel6.x-1.run

uname -m && cat /etc/*release
x86_64
IBM CMC 6 for RHEL 6.2
LSB_VERSION=base-4.0-amd64:base-4.0-noarch:core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarc:printing-4.0-amd64:printing-4.0-noarch
Red Hat Enterprise Linux Workstation release 6.4 (Santiago)

lspci | grep NVIDIA
VGA compatible controller: NVIDIA Corporation GT218 [GeForce 210] (rev a2)
VGA compatible controller: NVIDIA corporation GF110 [GeForce GTX 560 Ti 448 Cores] (rev a1)
… and two NVIDIA audio devices

gzip --version
gzip 1.3.12 Copyright © 2007 Free Software Foundation, Inc.

Any idea why that can be? Any help is appreciated!
Christoph

OK, I think I can answer my own question now.
(In case somebody is running into same problem)

It seems that the cuda installer itself as well as the unzipped files it uses exceeded my AFS disk quota. And since AFS never tells you, things just start behaving weirdly without proper error messages (e.g., I would have preferred a “disk quota exceeded” instead of a “gzip end of file”, but that’s a different AFS story.)

It did install something now, so if I will ask some more questions it will be different issues:)

Thanks for listening,
Christoph

The 5.5 runfile installer has been upgraded to have a rudimentary disk-size check, thought I’m not sure how it would handle an AFS disk quota.

It basically parses df to get available size, and alerts you if you’re under.