have problem with torch cudnn (Solved)

hi i am trying to run neural network with torch. using lua
but it says there is no cudnn library. even if i have and also set the path on bashrc

how can i fix this problem?

i had libcudnn v5. and the error also said there is no libcudnn.so.5 in directory

please help

thank you

If

ls /usr/lib/aarch64-linux-gnu/libcudnn*

shows libcudnn.so.5, then the library is installed on your Jetson and you may add its path to environment variable LD_LIBRARY_PATH (where the linker looks for libs):

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib/aarch64-linux-gnu

.

for the first cudnn was in the library you mentioned.
but i deleted the cudnn(v6) in there, and installed cudnn v5 on /usr/local/cuda-8.0/lib64
also its on LD_LIBRARY_PATH and CUDNN_PATH

Hi,

Please remember to install cuDNN package directly from JetPack.

There are some dependencies between OS and CUDA toolkit.
Please make sure your OS and libraries comes from the identical JetPack.

If you want to use cuDNN v5, please flash the device with JetPack3.0.
If you want to use cuDNN v6, please flash the device with JetPack3.1.

Thanks.

hi i reinstalled Jetpack3.0 and i can see cudnn libaray in /uar/local/aarch64-gnu folder
and i installed torch
installed cudnn for torch through luarocks

also set CUDNN_PATH to the folder which has cudnn.so.5 file is

and when i run
require ‘cudnn’
it still says it cant find library

please help me

Hi,

Please install cuDNN directly from JetPack.
Package from another source will lead to error.

This tutorial can give you some hint:
https://github.com/dusty-nv/jetson-reinforcement/blob/master/CMakePreBuild.sh#L128

Thanks.