Having a hard time with a carrier board

Hi guys,

I’ve been using the TX2 with the developer board to develop a ROS application. My TX2 receives images from a Windows computer via Ethernet over USB, using the micro-AB cable provided by Nvidia when you buy the developer kit.

However, I bought the Sprocket carrier board from Connect Tech (http://connecttech.com/product/sprocket-carrier-nvidia-jetson-tx2-jetson-tx1/) and I can’t reproduce my setup.
This board has also a micro USB OTG, and I use the same cable (the Nvidia one) to connect to it.

What I can do :

  • Start the TX2, put it in Recovery mode and flash the L4T image with the BSP (Board Support Package) provided by Connect Tech)

What I can’t do :

  • When the TX2 reboot after flashing, I don’t see it as a mass storage device, and I can’t access it via SSH over USB at 192.168.55.1.
    Also it is not visible on neither Linux nor Windows.

Actions I took :

  • I contacted the Connect Tech support, but they didn’t yet responded.
  • Tried with the stock L4T distribution
  • Tried different cables

Have you got any ideas? I am very frustated and feel kinda dumb, I am sure it’s simple in the end.
If you have any feedback with Connect Tech products I’m all in.

You can download L4T 28.2 and then install the BSP and flash the OS even if the Connect Tech says it only supports 28.1. It did the trick.

Cheers,