Having trouble installing OFED on OL.

Getting error when I ran ./mlnxofedinstall --fw-image-dir /tmp/my_fw_bin_files --add-kernel-support to install OFED for OL. Error details :

ERROR: Failed executing "MLNX_OFED_SRC-5.2-2.2.0.0/install.pl --tmpdir /tmp/MLNX_OFED_LINUX-5.2-2.2.0.0-4.14.35-2047.501.2.el7uek.x86_64/mlnx_iso.61842_logs --kernel-only --kernel 4.14.35-2047.501.2.el7uek.x86_64 --kernel-sources /lib/modules/4.14.35-2047.501.2.el7uek.x86_64/build --builddir /tmp/MLNX_OFED_LINUX-5.2-2.2.0.0-4.14.35-2047.501.2.el7uek.x86_64/mlnx_iso.61842 --disable-kmp --build-only --distro ol7.8"

How can I fix this ?

Hi Chandra,

Please note that according to the release notes the current kernel is not supported

https://docs.mellanox.com/display/OFEDv522200/General+Support+in+MLNX_OFED

latest kernel supported for OL 7.8 is 4.14.35-1902.300.11.el7uek.x86_64

The current kernel 4.14.35-2047.501.2.el7uek.x86_64 will be supported on the next MLNX_OFED 5.3 that will be released end of this month (March 2021) .

Thanks,

Samer

Still seeing the issue with new release.

ERROR: Failed executing "MLNX_OFED_SRC-5.3-1.0.0.1/install.pl --tmpdir /tmp/MLNX_OFED_LINUX-5.3-1.0.0.1-4.14.35-2047.501.2.el7uek.x86_64/mlnx_iso.113956_logs --kernel-only --kernel 4.14.35-2047.501.2.el7uek.x86_64 --kernel-sources /lib/modules/4.14.35-2047.501.2.el7uek.x86_64/build --builddir /tmp/MLNX_OFED_LINUX-5.3-1.0.0.1-4.14.35-2047.501.2.el7uek.x86_64/mlnx_iso.113956 --disable-kmp --build-only --distro ol7.9"

ERROR: See /tmp/MLNX_OFED_LINUX-5.3-1.0.0.1-4.14.35-2047.501.2.el7uek.x86_64/mlnx_iso.113956_logs/mlnx_ofed_iso.113956.log

Failed to build MLNX_OFED_LINUX for 4.14.35-2047.501.2.el7uek.x86_64