HDMI audio sometimes not work

I noticed that sometimes is not detected HDMI in pulse audio. Sound work only on Speaker (tegra-rt5639)

Logout and login or ‘pulseaudio -k’ helps and HDA NVIDIA Tegra is visible.

if someone has already met with this??

I have the same problem. It didnt wok at all on older Sony tv but on newer Samsung tv, I have to turn the tv off and on, which usually makes the sound work

I have the same problem. I have never even heard a sound from my TCL TV, but the tegra-rt5639 works fine.

Must be a sofware problem, to me it sometimes just doesnt work, most of the time actually.

You can use followin command to load the HDA device manually:

pactl load-module module-alsa-sink device=hw:o,3

This should eliminate the need to log out.

“Module initialization failed”

Are you trying this from ubuntu desktop terminal itself or from ssh?

You need to be logged in first through ubuntu-desktop so that pulseaudio daemon starts and you can run the command.

If possible, please provide the complete logs with commands and output.

Ubuntu desktop terminal. Nevermind this. pulseaudio -k seems to work now.

Hi,
Please try replacing your /etc/pulse/default.pa with this one attached. (had to make it .txt since .pa is invalid here)
It should work now.
default_pa.txt (5.65 KB)

I have tried replacing the default.pa file provided but I still don’t get audio over HDMI. I have the grinch kernel and am connected to a Samsung HDMI 24" TV. I do see a lot of messages in dmesg like:
tegradc tegradc.1: hdmi: can’t set audio to 44100 at 154012000 pix_clock

Display works fine but no audio.

Thanks

I actually gave up. I’m using hdmi to vga and a 3.5mm jack :/

All I had to do was edit /etc/pulse/default.pa and add the following at the bottom

set-card-profile 0 output:output:hdmi-stereo

Audio every boot now without issue.

I did this and it works on 19.3.7 grinch, BUT it won’t keep the default audio on hdmi. it always reverts to analog on reboot.

I’ll see what a plain 21.1 clean flash does tonight.

Hi beowulfs,
That is the expected behavior. I guess you can look around and change default.pa to have HDMI set as default.
I will update here in case I get time to check this.

Hello guys and happy new year!

I’ve lots of trouble with the sound over HDMI. Having tried everything suggested on the forum I’m starting to think that probably the kernel is not well configured to play with the most recent 2014 TVs…

There is a typo in comment #5.
Device is hw:0,3 instead of hw:o,3.

Please note there is a typo in comment #5,

the command to load HDA module is:
pactl load-module module-alsa-sink device=hw:0,3

Here, device is hw:0,3 instead of hw:o,0.

This can be made default by making below changes (if not already done):

  • uncomment line with module-alsa-sink in /etc/pulse/default.pa
  • change device value to hw:0,3 # Check playback hardware list using aplay -l for this having HDA device (aplay -l | grep -ie hda)

So your default.pa file should have this working entry,
ubuntu@tegra-ubuntu:~$ cat /etc/pulse/default.pa | grep -ie module-alsa-sink
load-module module-alsa-sink device=hw:0,3

Thanks
Mohit Sharma