HDMI Display does not work after update to JetPack 5.0.2

上面的 flash log,对应的是 a04 pinmux。

后面我调整为自定义pinmux,flash log如下。
flash-new-board-调整pinmux后.log (85.1 KB)

Hi,

I will check this internally. AFAIK, there is a little messy in the handling of this part (different sku)…
Some patches are there in our internal code for this part. But I need to make a summary for it.

我想我发现问题原因了,谢谢。
我把烧录分成了以下2步,第1步如果usb没有正常连接 module或module没有进入recovery模式,extlinux.conf默认使用 0000版kernel。
sudo ./flash.sh --no-flash jetson-agx-orin-devkit mmcblk0p1
sudo ./flash.sh -r jetson-agx-orin-devkit mmcblk0p1

Hello,

So if you use full flash from the beginning with module in RCM, extlinux will set it to 0004 version?

Yes

Okay. Thanks for the clarification. Hope this may help other users too.
Better running full flash here to avoid problem.

As for your request about the lane swapping, I am still discussing the feasibility with internal team.

Thanks too much.

HI,

Sorry that I just confirmed. This (lane swap) is not supported on Orin software.

Xavier and some older platform’s software supported this. But Orin does not due to the software structure has been changed.

Thank you all the same. This topic can be closed.

Hi @nkpyq

抱歉再跟您詢問下 請問你最後
Board ID(3701) version(500) sku(0000) revision(H.0) 還有Board ID(3701) version(500) sku(0004) revision(G.0) 這兩款module在你們的底板上HDMI function都ok了是嗎

還是只有其中一款module可以?


Sorry to ask one question here. Are both modules you mentioned working fine in HDMI? Or only one module can work fine?

这两款 HDMI function 都ok了。

1 Like