HDMI doesn work anymore

Hi all,
This morning, i´ve cleaned up my desk. Dismounting all computer / card.
Yesterday evening, my TX2 worked perfectly with my HDMI monitor. But not anymore. Nothing changed. Same keyboard, same mouse and same monitor, same hdmi cable.
Jetson bootup correctly but with black screen. I can ssh to it and x is launched but on a DFP-0 monitor.
There´s no DFP screen here. Only HDMI. Before that was HDMI-0 in x log.
If i type xrandr --display :0 from ssh the msg appear:
Invalid MIT-MAGIC-COOKIE-1 keyCan’t open display :0
No error in log about HDMI ;( The only msg in dmesg about hdmi is: [ 1.552062] vdd-hdmi: 5000 mV

Monitor and cable work on another computer.
Is it possible that there´s a soldering problem since removing dust with clean air and light antistatic brush?

Does your monitor work in console mode (Alt-Ctl-F1) ?

HDMI is hotplug. If you unplug it and replug 10 seconds later, does it improve ? Do you see errors in dmesg when doing so ?

You may check if the EDID is read correctly from your monitor

sudo cat /sys/kernel/debug/tegradc.1/edid

and check its content by pasting its hexadecimal output on http://www.edidreader.com.

One extra note if other fixes don’t help or give debug info…the MIT-MAGIC-COOKIE is a security thing. It is a temporary file, and is a method to aid deciding who can display on the monitor or not. In other words, even if the monitor works some software may be denied use of the monitor if that temp file is stuck after a crash, non-clean shutdown, so on. Displaying from one user’s login to another user’s screen would also fail without steps to allow it. Each home directory has a “~/.Xauthority” file…you may want to delete any which already exist (e.g., “~nvidia/” and “~ubuntu/” or anyone in “/home/”) and reboot. You may also want to check the “~/.xsession-errors” file of each user account and see if anything notable is mentioned. An example of this going wrong might be if sudo was used in such a way that the “~/.Xauthority” became owned by root and the actual user was no longer allowed to delete or modify the file.

Thanks for your help. But i think that´s a hardware problem.
Removing and replugging the hdmi cable do nothing in dmesg.
X start because of the “AllowEmptyInitialConfiguration” “true” configuration.

Part of my Xorg.0.log:
8.739] (II) NVIDIA(0): Creating default Display subsection in Screen section
“Default Screen Section” for depth/fbbpp 24/32
[ 8.739] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[ 8.739] (==) NVIDIA(0): RGB weight 888
[ 8.739] (==) NVIDIA(0): Default visual is TrueColor
[ 8.739] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 8.739] () NVIDIA(0): Option “AllowEmptyInitialConfiguration” “true”
[ 8.739] (
) NVIDIA(0): Enabling 2D acceleration
[ 8.741] (–) NVIDIA(0): Valid display device(s) on GPU-0 at SoC
[ 8.741] (–) NVIDIA(0): DFP-0
[ 8.741] (II) NVIDIA(0): NVIDIA GPU GP10B (nvgpu) (GP10B) at SoC (GPU-0)
[ 8.741] (–) NVIDIA(0): Memory: 8042848 kBytes
[ 8.741] (–) NVIDIA(0): VideoBIOS:
[ 8.742] (==) NVIDIA(0):
[ 8.742] (==) NVIDIA(0): No modes were requested; the default mode “nvidia-auto-select”
[ 8.742] (==) NVIDIA(0): will be used as the requested mode.
[ 8.742] (==) NVIDIA(0):
[ 8.742] (–) NVIDIA(0): No enabled display devices found; starting anyway because
[ 8.742] (–) NVIDIA(0): AllowEmptyInitialConfiguration is enabled
[ 8.742] (II) NVIDIA(0): Validated MetaModes:
[ 8.742] (II) NVIDIA(0): “NULL”
[ 8.742] (II) NVIDIA(0): Virtual screen size determined to be 640 x 480
[ 8.742] (WW) NVIDIA(0): Unable to get display device for DPI computation.
[ 8.742] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default

.xsession-errors is 0 byte
No problem with .Xauthority file (my user is the owner).

Tomorow, i´ll try to reverse my compute module from my jetson-tx1 and jetson-tx2.

HDMI port not seen by the kernel. No boot screen, no tty, no x.

Hi arcangeli,

Have you confirmed that’s the HW problem?

You could follow RMA process to resolve the technical issue:
https://developer.nvidia.com/embedded/support

Thanks

Hi,
Yes it’s a hardware problem. The TX2 compute module work perfectly on my previous jetson-tx1. And TX1 module has no HDMI on the jetson-tx2 motherboard.

Thanks for the link.