HDMI keep blinking with "Started User Manager for UID 120" message

Hi all,

I’m facing “Started User Manager for UID 120” problem on Xavier with 32.1 kernel version.
I just tried to re-compile the kernel with default configuration “tegra_defconfig” and update by the command through recovery mode as below

sudo ./flash.sh -r -k kernel -K YOUR_KERNEL_ZIMAGE jetson-xavier mmcblk0p

Then when boot up the HDMI monitor keep blinking unlimited with “Started User Manager for UID 120” message as picture

But If I try with the kernel that come from “JAX-TX2-Jetson_Linux_R32.1.0_aarch64.tbz2” everything would be fine.
There is another topic for similar problem on TX2 as this link
https://devtalk.nvidia.com/default/topic/1051147/jetson-tx2/jetson-tx2-change-kernel-without-full-flash/1 but it look like still there is no proper solution.
Any help would be appreciated.

Vu Nguyen

Hi forever3000,

“sudo ./flash.sh -r -k kernel -K YOUR_KERNEL_ZIMAGE jetson-xavier mmcblk0p”

Could you share what file you are using and where do you put it?

Please note that we are using image instead of zImage.

Hi WayneWWW,

Due to I could not attach file in this forum so will post google drive link

“YOUR_KERNEL_ZIMAGE” would be replaced with correct path to Image file.


Per checked I can boot my device with your kernel. Would you mind using full flash?

With full flash I could see some screens for setting language, location, user and password. But after finish setting, the issue come back again.

Do you use the pure rootfs from jetpack??

Yes I’m using “JAX-TX2-Tegra_Linux_Sample-Root-Filesystem_R32.1.0_aarch64.tbz2” for rootfs.

Could you share your steps for us to confirm?

Yes, I just follow same as quick start guide

  1. Extract “JAX-TX2-Jetson_Linux_R32.1.0_aarch64.tbz2” then we have “Linux_for_Tegra” folder
  2. Extract “JAX-TX2-Tegra_Linux_Sample-Root-Filesystem_R32.1.0_aarch64.tbz2” to “Linux_for_Tegra/rootfs” folder
  3. Run “apply_binaries.sh” script
  4. Extract “JAX-TX2-public_sources.tbz2” to get kernel source code then re-compile kernel and device tree
  5. Copy Image from “$TEGRA_KERNEL_OUT/arch/arm64/boot” directory to “Linux_for_Tegra/kernel”
  6. Copy all device trees from “$TEGRA_KERNEL_OUT/arch/arm64/boot/dts” directory to “Linux_for_Tegra/kernel/dtb”
  7. Run flash script “sudo ./flash.sh jetson-xavier mmcblk0p1”

Looks no issue. Maybe the sample rootfs has some problem. We will check.

Would you mind using the rootfs from jetpack instead?

I tried with rootfs from jetpack and everything was same.

We can reproduce this issue. Still digging to the root cause.

Thanks, I think there is a little difference between Image from “JAX-TX2-Jetson_Linux_R32.1.0_aarch64.tbz2” and Image re-compile with “tegra_defconfig” configuration.
If I use Image from “JAX-TX2-Jetson_Linux_R32.1.0_aarch64.tbz2”, everything will work well.

I see “-K YOUR_KERNEL_ZIMAGE”. If you really used the zImage, try instead with the uncompressed Image.

Hi linuxdev, actually I used uncompressed Image not zImage.


Yes, we can reproduce this issue with umcompressed image.

May I know which toolchain are you using?

Hi WayneWWW, I’m using “gcc-linaro-6.4.1-2017.08-x86_64_aarch64-linux-gnu.tar.xz” downloading from jetson download center.

Could you try to use new gcc for cross compile?


Yes, I’m also downloading for testing again. Will update to you the result soon.