HDMI pixel clock higher than expected on cutom carrier board

hi sir
For HDMI tuning, we have configured the supported resolutions and actually hdmi clock are higher than expected as the following:

  1. 480p (27 MHz) → 33mhz is measured by external
  2. 720p (74.25 MHz) → 93mhz is measured by external
  3. 1080p (148.5 MHz) → 185mhz is measured by external

How can we check pll clock source or deep color is active? if deep color is active how it can be disable it?

Jetpack 6 DP
Jetson Agx Orin 32G
Customized carrier board

Hi,

Please share below info when each mode is connected.

root@tegra-ubuntu:/sys/kernel/debug/bpmp/debug/clk/hub# cat rate 
root@tegra-ubuntu:/sys/kernel/debug/bpmp/debug/clk/disp# cat rate 
root@tegra-ubuntu:/sys/kernel/debug/bpmp/debug/clk/nvdisplay_p0# cat rate 
root@tegra-ubuntu:/sys/kernel/debug/bpmp/debug/clk/nvdisplay_p1# cat rate 
root@tegra-ubuntu:/sys/kernel/debug/bpmp/debug/clk/vpll0# cat rate 
root@tegra-ubuntu:/sys/kernel/debug/bpmp/debug/clk/vpll1# cat rate 
root@tegra-ubuntu:/sys/kernel/debug/bpmp/debug/clk/emc# cat rate 
root@tegra-ubuntu:/sys/kernel/debug/bpmp/debug/clk/pll_hub# cat rate 
root@tegra-ubuntu:/sys/kernel/debug/bpmp/debug/clk/disppll# cat rate 
root@tegra-ubuntu:/sys/kernel/debug/bpmp/debug/clk/disphubpll# cat rate 

If possible, also dump same cases from rel-35.

Also, please provide the waveform result as your measurement.

Hi sir
Based on r36.2, see the below.
1080p
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/hub/rate
48214285
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/disp/rate
150000000
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/nvdisplay_p0/rate
148500000
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/nvdisplay_p1/rate
148500000
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/vpll0/rate
148500000
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/vpll1/rate
148500000
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/emc/rate
2133000000
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/pll_hub/rate
467000390
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/disppll/rate
1191000000
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/disphubpll/rate
12698437

720p
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/hub/rate
48214285
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/disp/rate
77142857
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/nvdisplay_p0/rate
148500000
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/nvdisplay_p1/rate
74250000
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/vpll0/rate
148500000
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/vpll1/rate
74250000
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/emc/rate
665600000
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/pll_hub/rate
467000390
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/disppll/rate
1191000000
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/disphubpll/rate
12698437

480p:
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/hub/rate
48214285
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/disp/rate
42857142
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/nvdisplay_p0/rate
148500000
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/nvdisplay_p1/rate
27000000
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/vpll0/rate
148500000
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/vpll1/rate
27000000
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/emc/rate
2133000000
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/pll_hub/rate
467000390
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/disppll/rate
1191000000
root@l-desktop:~# cat /sys/kernel/debug/bpmp/debug/clk/disphubpll/rate
12698437



Hi,

Did you follow the tuning guide document to probe the signal?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.