HDMI port on NVIDIA DRIVE AGX with 5.2.6 drive OS not working properly

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
[*] DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System
[*] Linux

Hardware Platform
[*] NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
[*] native Ubuntu 18.04

Hi ,

At first display is working but after reboot then display is not working
followed this post as well . this solution not worked for me


Dear @balakrishnan.ayyanar,
Please check if Display manager gets destroyed after reboot is related?

Dear @SivaRamaKrishnaNV ,

Yes it seems same issue. Could not understand the solution


Dear @balakrishnan.ayyanar,
The issue in the shared post is, the system gets updated automatically and noticed display after reboot.
Please check disabling auto updates(select never in check auto updates) as given in Display manager gets destroyed after reboot - #10 by anil-kumar.chavali

Thanks . it solved problem. I have to reflash it and do steps mentioned above.
I have concern that if some other software installation required to run (sudo apt-get upgrade ) then it could be an issue.

Other question have is after flashing os (from 5.1.6 to 5.2.6) I could not found the storage space which was there in /ota/pkg_data/ in 5.1.6 . it was around 100GB before but could not found that location in new OS . Sorry this was not related to above post . if needed will create new topic


Dear @balakrishnan.ayyanar,
Please create new topic for each issue if it is not related to current topic.

Understand. thanks
Created as issue here

Even after setting the automatic upgrade stopped , this issue came again . under /etc/gdm3 is deleted automatically. Why this issue coming up in 5.2.6(recommended by NVIDIA). if we go back to older OS(5.1.6) can we avoid this issues or it is problem of re flashing ?

Dear @balakrishnan.ayyanar ,
We did not notice display issues on DRIVE SW 10 release. But it has DRIVE OS 5.1.6 and DW 2.2.
You may check flashing DRIVE OS 5.2.0 + DW 3.5 release as well.

First we moved to the version 5.2.6 to avoid this issue mentioned here

We developed the ROS driver for sensors again for 5.2.6( Since drive work SDK is different from 5.1.6) and butwe face issue with HDMI port and the other ports in 5.2.6 .

then we give up the idea of using cupy and try to go back to 5.1.6 , if we use 5.2.0 again we have to check cupy and develop the ROS drivers .