Hdmi, usb, and ethernet not receiving signal/power after green light turns on

Problem:
I got a Jetson Nano Developer Kit a couple months ago, and within the last two weeks, about 80-90% of the times I’ve applied power none of the hdmi, usb, or ethernet ports have received signal/power, so I’m unable to login or see the boot sequence.

What I’ve tried:
-Multiple power sources (verified with a multi-meter):

  1. usb-micro 5v 3a power supply boots correctly 10-20%
  2. barrel jack: has to be held in a specific position otherwise green light doesn’t even turn on, so not repeatable.
  3. Using a Drok buck converter with an output of 5.2V to account for voltage drop (rated for over 6A) connected in parallel to the two 5V pins (2 and 4) and the two GND pins (6 and 9) on the J40 header. Boots correctly 10-20% of the time.
    -Reimaged and Re-partitioned 64 GB Sandisk Micro SD card multiple times
    -Tested Monitor, hdmi cable, ethernet cable, and usb peripherals separately, and they work.

Things to try:
-Using TTL/UART to USB adapter to see boot sequence?
-Replacing the board?

Does anyone else have other solutions or things to try to fix the problem?

If your board “suddenly” not able to work, and you don’t do any upgrade or connect any new peripherals, then it is probably hardware issue.

But please still try to dump the serial console log for us to check. Thanks.

IMO, this is a problem with your cable. I experienced this before, can you use other cable? I cut my laptop charger cable for this and it now works more consistently.

The issue appeared around the time that I started using a USB to CAN adapter by CANable, but I’m guessing it’s more correlation than causation because the problem occurs whether it’s plugged in or not, even after I’ve re-imaged the SD card.

It’ll take a couple of days for me to order and receive the adapter, and then I’ll probably use the tutorial by Jetson Hacks to dump the serial console log.

Thank you.

I’ve tried a couple different cables, and I’ve had to hold them for the green light to turn on. I’m guessing that it’s a port issue, but I could be wrong.

It sounds like your barrel connector (on the carrier board) is worn out and mechanically glitchy. Those kinds of connectors are generally only rated for 50 cycles.

You could try to supply 5V power through the 40-pin GPIO instead. 5V to pin 2 and GND to pin 6 works well for me.

Here’s the serial console dump without any peripherals plugged in:

[0000.120] [L4T TegraBoot] (version 00.00.2018.01-l4t-2d758fea)
[0000.126] Processing in cold boot mode Bootloader 2
[0000.130] A02 Bootrom Patch rev = 1023
[0000.134] Power-up reason: pmc por
[0000.137] No Battery Present
[0000.140] pmic max77620 reset reason
[0000.143] pmic max77620 NVERC : 0x40
[0000.146] RamCode = 0
[0000.149] Platform has DDR4 type RAM
[0000.152] max77620 disabling SD1 Remote Sense
[0000.156] Setting DDR voltage to 1125mv
[0000.160] Serial Number of Pmic Max77663: 0x317d6
[0000.167] Entering ramdump check
[0000.170] Get RamDumpCarveOut = 0x0
[0000.174] RamDumpCarveOut=0x0, RamDumperFlag=0xe59ff3f8
[0000.179] Last reboot was clean, booting normally!
[0000.183] Sdram initialization is successful
[0000.188] SecureOs Carveout Base=0x00000000ff800000 Size=0x00800000
[0000.194] Lp0 Carveout Base=0x00000000ff780000 Size=0x00001000
[0000.199] BpmpFw Carveout Base=0x00000000ff700000 Size=0x00080000
[0000.205] GSC1 Carveout Base=0x00000000ff600000 Size=0x00100000
[0000.211] GSC2 Carveout Base=0x00000000ff500000 Size=0x00100000
[0000.217] GSC4 Carveout Base=0x00000000ff400000 Size=0x00100000
[0000.223] GSC5 Carveout Base=0x00000000ff300000 Size=0x00100000
[0000.229] GSC3 Carveout Base=0x000000017f300000 Size=0x00d00000
[0000.245] RamDump Carveout Base=0x00000000ff280000 Size=0x00080000
[0000.251] Platform-DebugCarveout: 0
[0000.254] Nck Carveout Base=0x00000000ff080000 Size=0x00200000
[0000.260] Non secure mode, and RB not enabled.
[0000.264] Read GPT from (4:0)
[0000.403] Csd NumOfBlocks=124735488
[0000.408] Set High speed to 1
[0000.411] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWai
[0000.421] Command complete wait failed with error 0x3 Interrupt 0x18001
[0000.427] Number of retries left 4
[0000.439] Using GPT Primary to query partitions
[0000.444] Loading Tboot-CPU binary
[0000.453] Verifying TBC in OdmNonSecureSBK mode
[0000.463] Bootloader load address is 0xa0000000, entry address is 0xa0000258
[0000.470] Bootloader downloaded successfully.
[0000.475] Downloaded Tboot-CPU binary to 0xa0000258
[0000.479] MAX77620_GPIO5 configured
[0000.483] CPU power rail is up
[0000.485] Invalid Oscillator Freq
[0000.489]

Assert on NvTbootGetOscFreqKhz:104: 0
[0000.493]

Assert on NvTbootInitPllX:199: OscFreqKhz

Let me know if you need anything else.
Thank you.

Yes, looks like a hardware issue because cpu clk is not enabled.

Could you try to re-flash the board and see if flashing also fails?

I reflashed the board twice; the first time I reflashed the SD card, and the second time I used the nvidia SDK manager. I checked the serial logs after both attempts, and both logs were the same as the one above.

Ok, then please RMA this device. It is hardware defect.