Hdml display sometimes blinked

Now, I’m using JetPack3.2.1.
Then, I am displaying movie by using nvoverlaysink of gstreamer1.8.3.
However, I have a problem.
Hdmi display sometimes blinked to black.
At that time, in console. the follwoing message displayed.

[ 1000.810764] tegradc 15210000.nvdisplay: blank - normal
[ 1003.783646] tegradc 15210000.nvdisplay: unblank

I saw the similar problem in this forum.
But, I cound not found this solution.
Is there any advice?

Incidentally, my usging HDMI display is 4K(3840x1920) size and 60Hz.


Please share more detail about how to reproduce your issue.

Is running gstreamer with overlaysink a must-have element for reproducing your issue? Does this error come suddenly without doing anything? Have you tried other montior or modes on your 4k monitor?

Thank you for your quick response.

I have the same problem also in JetPack3.2

a most simple script that I’m using in a console window is the followings.

gst-launch-1.0 -v -e
rtspsrc location=rtsp://xx.xx.xx.xx:554
! rtph265depay
! h265parse
! omxh265dec
! nvoverlaysink

Input Image size is precisously 3840x960 and 30fps.

this problem happens always and irregular.

I have two kind 4k monitor, but same company (IODATA).
It happens the same problem in two kind monitor.

I also will try the other monitor.


Since we don’t have a video sample that is 3840x960@30, could you try to use some samples with common mode(720p, 1080p) and see if the error is still?

Also, could you also share full dmesg and syslog after the error is reproduced?

I can reproduce also both 3840x2160@30 and 1920x1080@30.

In console window, in a case of 3840x960@30, I can see both of movie and console message.
Then, when a movie was blinked, a console message also disappeared.

I thought that this is some about suspend mode.
Therefore, I tried the following command.

sudo systemctl unmask sleep.target suspend.target hibernate.target hybrid-sleep.target

However, this probrem was not solved.

I will attached th full dmesg log and syslog.

syslog.zip (149 KB)
dmesg.zip (21 KB)


According to your syslog, I notice there is a 3-min period that the display goes to powerdown and then unblanks again. Does gstreamer a must-have component for reproducing this issue? It looks more like a auto-suspend or sleep.

Are you using nvidia devkit for this test? Do you have ubuntu-GUI enabled when running this test?
Please remember to change different HDMI cable in test as well. How about using nvcamerasrc or filesrc instead of rtspsrc in pipeline?

Thank you for your thinking about variaous case.

I’m thinking also this is like a auto-supend or sleep.
However, I didn’t know how to cancel it.

Then, I tried the follwoing command.

setterm --blank 0

Maybe, this problem solved.

Best Regards,


Glad to hear that the issue seems resolved.