Hello AI World: Using ./imagenet Creates Endless Loop of Tactic Finding?

I’m having a really strange issue when I try to run imagenet or detectnet in the container.

I got into the directory:
cd jetson-inference/build/aarch64/bin
Then I applied the code :
./imagenet.py images/orange_0.jpg images/test/output_0.jpg

And I got this strange issue where the terminal just shows an endless loop of going through different “Tactics” then showing some preprocessing steps, then repeating the same thing.
I’ve also tried this with the jellyfish video and with the webcam and the program just goes insane. Here are some screenshots of what it looks like in the order they happened:







(In the last one I used ctrl+c to stop it which worked, but with images when webcam that doesn’t work)

It does this repeatedly, and when i used detectnet with webcam i couldn’t even get this to stop with the ctrl+C command. I hit to directly close the terminal.
This also triggers a “System throttled due to low input voltage” alert.

I’m not sure why it’s responding this way and would really appreciate some help.

Device details: Nano 2GB, 4GB swap size with a CSI camera

Hi,

The “Tactic” log is from TensorRT and looks normal to me.

In the first run, TensorRT will try to convert the network into TensorRT engine.
And the log is the detailed information when it tries to find a faster algorithm.

You can set the log level to ERROR.
So the verbose log won’t print out.

Thanks.

I will try running it again, but it seems to go through this process for quite a bit of time.

Hi @siftikh1, for classification models like googlenet or resnet18, it can typically take around 5 minutes for TensorRT to optimize the network on Nano 2GB (although that time can vary as it is profiling different kernels on the GPU to find the configuration of DNN layers that runs fastest). This should only occur the first time you load a particular model - after it’s optimized, the optimized model will be saved to disk and then loaded straight away on further runs.

1 Like