Help adding display to Oculus Rift S

I’ve managed to get the Oculus itself working, but I’m having issues with the display. When I run xrandr what I see are my 3 connected monitors, and not the Rift. I’ve attempted adding Option "AllowHMD" "yes" to Section "Screen" /etc/X11/mhwd.d/nvidia.confand I’ve tried adding that to Section "OutputClass", then I made /etc/X11/xorg.conf.d/11-nvidia-hmd.conf with just:

Section "OutputClass"
    Identifier     "Nvidia HMD"
    MatchDriver    "nvidia-drm"
    Driver         "nvidia"
    Option "AllowHMD" "yes"

to no avail. What else can I do?
System Specs:
Kernel: 5.15.32-1-MANJARO
DE: Plasma 5.24.4
CPU: Intel i7-4790K (8) @ 4.400GHz
GPU: NVIDIA GeForce GTX 1070 Ti
GPU: Intel HD Graphics

Please check this thread:

Hm, it does not appear to be working still. I now have 2 files, both called 10-nvidia.conf in /etc/X11/xorg.conf.d and /usr/share/X11/xorg.conf.d with just the output close I showed above. I also tried running my script, which just contains:

osvr_server /usr/share/osvrcore/sample-configs/Oculus_Rift_DK1.json

And I didn’t see any new connections either, though I believe this only allows the Rift to work, not display.