Help building nvgstcapture-1.0 and NV GST Apps

I’m trying to build L4T NV GST Apps v23.2 from the source provided on NVIDIA’s site.
It does not include these headers which are required by nvgstcapture-1.0:

#include <eglapiinterface.h>
#include "gstnvcamera_public.h"
#include "nvgstcapture_gui_interface.h"

Where can I get these dependencies? Thanks!

Hello, hammer00:
Would you please tell me where you downloaded the nvgstcapture-1.0 source?


I got it from the Embedded Download Center. It’s called L4T NV GST Apps sources 23.2 2016/03/02

Hello, hammer00:
thanks for pointing out that issue.
I will check internally and give you feedback after investigation.



I am running the dependency issue when trying to build nvgstcapture1.0.

Here is the link to the source:

Snippet of the build output:
In file included from nvgstcapture.c:25:0:
nvgstcapture.h:40:29: fatal error: eglapiinterface.h: No such file or directory
#include <eglapiinterface.h>
compilation terminated.

Appreciate any help on this.

Have you solve the problem?I meet the same problem?

Appreciate any help on this.
By Zhangyeyan

Hi zhangyeyan,

This issue should be resolved in r24.2?
What’s the BSP you’re using now?

I am using r27.1.0 and cannot resolve this dependency. I see the same problem. Can you please help?

We have confirmed this issue and it will be fixed in next release.

I’m trying to build NV GST Apps JetPack 3.0 / L4T R27.1 from the source provided on NVIDIA’s site. yesterday.

It still does not include these headers which are required by nvgstcapture-1.0

Hi all, same prob here using R28.1.
Trying to build NVGST apps for debug purposes.

Worked like charm by using JetPack installer. Able to run nvgstcapture on TX1 from console.

Any Idea what’s missing when I’m trying to build

Here is an excerpt with the include files which are required but not found on TX1.

#include <eglapiinterface.h>

#include "gst/pbutils/pbutils.h"
#include "gst/pbutils/encoding-profile.h"
#include "gst/pbutils/encoding-target.h"
#include "gstnvcamera_public.h"

Hi stroblme,
Looks like you are building r24.1 on r28.1. Can you try r28.1 package?

Hi DaneLLL,

thanks, I’ve already tried using this package but when extracting it on PC using 7-zip an error saying
“Data error in “…”. The file is corrupt”.
Extracting it on lx worked.

I’m able to compile the software, thanks for your help.