Help entering recovery mode

I tried installing a virtual display on my Jeston (Not working on Nvidia · Issue #9 · dianariyanto/virtual-display-linux · GitHub), which has prevented it from booting up correctly. It gets stuck on a voltage operation error that I know is related to what I just installed.

Now, I understand which files I need to alter to get it back up and running, however I do not know how to get access to those files. This is what I’ve tried so far:

  1. Starting in recovery mode by holding the shift key. I continue to get stuck, but usually far enough along where I will see “Started User Manager for UID 1000”, or “Started session 1 of user”, or “Started resolvconf-pull-resolve.service. Changes…” This tells me Linux is running, but I just can’t see it.
  2. I’ve tried pressing the recovery button on the Jetson when starting the board. However, I will only get indication that the board has turned on (green lights), but no output to the monitor. I’m also not sure this is really what I want.
  3. I’ve tried starting a live session off a USB, but I don’t know how to access the boot menu. I thought that holding the shift key would bring up the boot menu, but that doesn’t seem to be the case. I’ve also tried other key combinations, but nothing seems to make a difference.

I hope it’s pretty clear, I don’t know what I’m doing. I have some past experience with dual booting Linux on laptops, but the fact that I can’t access the boot menu on this Jetson is giving me a headache.

In the shortest form possible, how do I get into my system so I can modify the files necessary?

Thank you!

FYI, recovery mode does not change anything, and does not run a full operating system. All this does is make the most simple version of boot receptive so that flash software can be loaded into the Jetson for temporary use (all such software is just in RAM until flash software says to write). You would not change individual files with this, you would instead flash the entire system. Are you looking to install individual files?

If you want to edit files, and if the system is running, but the keyboard/mouse is inaccessible, then perhaps ssh would work. If not ssh, then serial console would be the next best bet. For serial console, see:
http://www.jetsonhacks.com/2017/03/24/serial-console-nvidia-jetson-tx2/

Incidentally, it is serial console which provides access to alternate boot entries which might exist in extlinux.conf. A very useful tool to have around. If you have serial console access, then you can pretty much edit anything you want without problem.

Thank you very much, I’m looking into setting up a serial console. Will a serial console allow me to bring up a terminal? I’m still fuzzy on who I can go about modifying system files when I can’t see anything past the boot messages.

As per you question, I only need to delete a specific file, which should then allow my Jetson to boot as normal.

Serial console is a full terminal (text mode only) in which you can do anything you could normally do on command line. This assumes the system is working, but much of the system can crash and burn with serial console still functioning. When things go wrong this is the most reliable access you have.

If first boot setup has been completed, then you will be offered to log in as that admin user using that password. Once logged in, if you want admin privileges, then you can prefix commands with “sudo” to have root authority (requiring your admin user password).

If for some reason the system is not able to boot to a point which allows login, then you might have to resort to flashing again (it is complicated and time consuming, but you could clone, edit the clone, and then flash with the repaired clone…not recommended unless you are patient and have lots of disk space…it takes time to do so, while serial console is close to “instant gratification”). Deleting a file with serial console login (if it works) is trivial.