Help, Jetson Nano and Wake on LAN

I enjoy controlling my Jetson Nano remotely through VNC by connecting it directly to my router using an Ethernet cable. However, the router is located far away and it’s inconvenient to keep connecting and disconnecting the device to turn it on and off. Recently, I remembered about the Wake on LAN (WoL) feature and tried to use it but couldn’t get it to work. Can you help me figure out what’s causing the issue?

These are the steps that I have taken:

  1. Jetson Nano (B01) connected to 12V with a jumper on J48 header.

  2. I’ve placed a jumper on the J50 header to disable the Auto On (to start with a push button).

  3. I obtained the MAC using ifconfig.

  4. I used “ethtool eth0” to check if Wake on LAN is active, the result is “Wake on LAN: g”, which according to the tables is active.

  5. Turned off the terminal, still connected to the power grid and LAN network.

  6. Sent wake-up packets to the device from both Android using Termux and Windows, the result… The Jetson remains off.

It’s most likely that I missed a step. Which one could it be?

Please try this one.

[Jetson]
$ sudo ethtool -s eth0 wol g
$ sudo systemctl suspend

[Host]
$ sudo apt-get install wakeonline
$ wakeonline -i

It worked!.. thank you so much!.. but this opens up a question for me, does WOL only work with the machine in a suspended state?

Yes, for jetson nano, only suspend state supports WoL. There is no power-off mode + WoL supported.