Help Needed on ERROR: NVIDIA driver is not loaded ASUS ROG

I have an ASUS ROG Strix GL553VD with a GeForce GTX 1050 Mobile running a dual boot with Windows 10 and Linux - Ubuntu 20.04.2 LTS with 5.4.0-77-generic kernel. Here all the specifications:

GL553VD
9905744-024.A00G
Intel(R) Core™ i7-7700HQ CPU @ 2.80GHz
Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers
Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16)
GP107M [GeForce GTX 1050 Mobile]
HD Graphics 630
Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th/8th Gen Core Processor Gaussian Mixture Model
100 Series/C230 Series Chipset Family USB 3.0 xHCI Controller
xHCI Host Controller
USB2.0 HD UVC WebCam
ITE Device(8910)
xHCI Host Controller
100 Series/C230 Series Chipset Family Thermal Subsystem
100 Series/C230 Series Chipset Family Serial IO I2C Controller #0
100 Series/C230 Series Chipset Family MEI Controller #1
HM170/QM170 Chipset SATA Controller [AHCI Mode]
100 Series/C230 Series Chipset Family PCI Express Root Port #3
Wireless 7265
100 Series/C230 Series Chipset Family PCI Express Root Port #4
RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
100 Series/C230 Series Chipset Family PCI Express Root Port #7
RTS5229 PCI Express Card Reader
100 Series/C230 Series Chipset Family PCI Express Root Port #9
XPG SX8200 Pro PCIe Gen3x4 M.2 2280 Solid State Drive
XPG GAMMIX S11 Pro
HM175 Chipset LPC/eSPI Controller
100 Series/C230 Series Chipset Family Power Management Controller
CM238 HD Audio Controller
100 Series/C230 Series Chipset Family SMBus
ADATA SU800

  • In Windows everything work with no problem.
  • In Linux however, the Nvidia drivers do not seem to load even though the card itself is recognized by the OS and the driver 460 is installed as well.
  • The main reason for doing all the nvidia-driver instalation is to be able to use Cuda 10.1 (which is already installed)
  • Secure Boot is also enabled.
  • I have spent lots of hours looking for a solution online so far, and even though I tried a few things nothing worked.

uname -r shows (Kernel):

5.4.0-77-generic

lspci -k | grep -A 2 -i "VGA" shows:

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04)
DeviceName: Onboard IGD
Subsystem: ASUSTeK Computer Inc. HD Graphics 630

lshw -C video shows:

*-display UNCLAIMED
descripción: 3D controller
producto: GP107M [GeForce GTX 1050 Mobile]
fabricante: NVIDIA Corporation
id físico: 0
información del bus: pci@0000:01:00.0
versión: a1
anchura: 64 bits
reloj: 33MHz
capacidades: bus_master cap_list
configuración: latency=0
recursos: memoria:de000000-deffffff memoria:c0000000-cfffffff memoria:d0000000-d1ffffff ioport:e000(size=128)
memoria:df000000-df07ffff
*-display
descripción: VGA compatible controller
producto: HD Graphics 630
fabricante: Intel Corporation
id físico: 2
información del bus: pci@0000:00:02.0
versión: 04
anchura: 64 bits
reloj: 33MHz
capacidades: vga_controller bus_master cap_list rom
configuración: driver=i915 latency=0
recursos: irq:142 memoria:dd000000-ddffffff memoria:b0000000-bfffffff ioport:f000(size=64) memoria:c0000-dffff

nvidia-smi shows:

NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

nvidia-settings show:

ERROR: NVIDIA driver is not loaded

ERROR: Unable to load info from any available system

(nvidia-settings:15148): GLib-GObject-CRITICAL **: 05:03:02.445: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed
** Message: 05:03:02.448: PRIME: Requires offloading
** Message: 05:03:02.448: PRIME: is it supported? yes
** Message: 05:03:02.479: PRIME: Usage: /usr/bin/prime-select nvidia|intel|on-demand|query
** Message: 05:03:02.479: PRIME: on-demand mode: “1”
** Message: 05:03:02.479: PRIME: is “on-demand” mode supported? yes

dkms status shows:

nvidia, 460.84, 5.4.0-77-generic, x86_64: installed

dpkg -l |grep nvidia-prime shows:

ii nvidia-prime 0.8.16~0.20.04.1 all Tools to enable NVIDIA’s Prime

dpkg -l |grep ubuntu-drivers-common shows:

ii ubuntu-drivers-common 1:0.8.6.5~0.20.04.1 amd64 Detect and install additional Ubuntu driver packages

nvidia-bug-report.log.gz (127.4 KB)

Please any help would be welcome

Disable secure boot from BIOS settings.