help TK1 won't boot after flashing to R21

i recenly upgraded to R21, well tried to. I d/l jetson jetpack on host linux 14.04 computer and it seemd like it d/l and installed ok . i did get an error that says armhf cross compiler wans’t found so I instaled that and re did jetpack. when i thought it flashed ok and i rebooted TK1 it just hangs up and i can’t see anything. it’s a blank screen all the time. the monitor is on and the fan is spinning so it’s doing something but i do not see anything happening. normally it’ll take me to ubuntu screen. is there a way to go back to original image or some how recover this? i have tried pressing different buttons but no luck. please help i think the board is hosed or stuck somewhere. thanks

Just flash shouldn’t be asking for a cross compiler. The armhf is just the hard float calling convention used when compiling for Jetson, but since flash shouldn’t use a compiler this can probably be ignored. More important is to give a detailed list of the commands used to verify details which instructions don’t always give…and to figure out why it wanted a cross compiler in the first place.

To start with, I’m not sure what the “jetpack” is…I’m assuming it is just the L4T R21.1 download file.

Next assumption is that although your host is correct to be linux, you also must verify the filesystem underneath it is a linux filesystem…so something like vmware with linux running on top of a windows partition will fail.

Another assumption is that you used sudo or root on every single step…some strange failures can show up if permissions are off.

After unpacking the sample rootfs has to be in place and the “./apply_binaries.sh” must be run. Now you are actually ready to go into recovery mode and flash. What was the exact flash command used?

thanks for the suggestions. i tried the whole process over and over again and finally went through. no idea what i did different but now i’m able to get ubuntu up and running and it seems much cleaner than R19.

jetpack is the all in one pkg that they had on the web

i used this one instead of doing it manually: ./flash, etc. i think it’s the same thing but using a separate host linux computer

how can u tell if this is running R21 or not?? way to check the vesrion of the board?

it seems like cuda didn’t get installed although jetpack said it did and built samples. i guess i’ll have to install that manually now…