Help with .aar files.

Hi there,

The Millennial Media SDK (advert provider) now uses .AAR files for deployment.

I’ve tried to use this in our project by doing the following:

Changed the Linker->General->Additional Library Directories to point at the directory with the .aar file in.
Added the name of the .aar file (mm-ad-sdk) to Linker->Input->Additional Dependencies.

The linker fails to find the .aar file with

cannot find -lmm-ad-sdk
collect2.exe : error : ld returned 1 exit status


Additional things I’ve tried:
Renaming the .aar file to mmsdk.aar in-case it was getting confused by the dashes in the filename.
Adding .aar to the dependencies with and without the .aar extension.

Is it possible to use .aar files?

Help much appreciated,




As I understand, you’re trying to add them as libs to GCC linker. And this is totally wrong. Try add them in Ant/Gradle properties of project.

Could you be more specific please?

Say I have x.aar I need to add to a project that uses ant (not Gradle). Where do I add this?
I’ve added it to pretty much every line in the project->properties->ant build dialogs (and sub branches) to no avail.