Help with TCP Camera Connection in VST v1.2.52


I’m currently working on setting up a TCP camera connection using VST v1.2.52, and I’m encountering some issues. Here’s a brief overview of my current configuration and the steps I’ve taken so far:

Network Settings (JSON):

    "rtsp_streaming_over_tcp": true

Despite setting rtsp_streaming_over_tcp to true in the network settings, I can still not establish a TCP camera connection. Additionally, I attempted to configure the sensor settings through the GUI to use rtspt instead of rtsp, but I encountered errors and could not proceed.

Specific Issue:

When trying to set the protocol to rtspt in the sensor configuration GUI, I receive an error message and cannot save the settings. It seems the configuration is not being accepted.


  1. RTSP over TCP Configuration:
  • Is there any additional configuration required to enable RTSP streaming over TCP?
  • Are there specific parameters or settings that need to be adjusted in the JSON configuration or elsewhere to ensure a successful TCP connection?
  1. Sensor Configuration GUI:
  • Are there any known issues or limitations with configuring rtspt through the sensor configuration GUI in VST v1.2.52?
  1. General Advice:
  • Are there any best practices or troubleshooting steps for setting up TCP camera connections in VST that I might have overlooked?

Any guidance or documentation from the community or the NVIDIA team would be greatly appreciated. Ensuring a stable TCP camera connection is crucial for my project, and any help would be beneficial.

Thank you in advance for your assistance.

I will check internally and feedback here. The new version MMJ will release soon. Please also try it on the new version of MMJ when it is available.

Can you share how you check if the RTSP connect over TCP or UDP?

Can you have a check your camera with below command line?
$ gst-launch-1.0 rtspsrc protocols=udp latency=100 location=rtsp:// ! rtph264depay ! h264parse ! nvv4l2decoder ! nvvideoconvert ! nv3dsink
$ gst-launch-1.0 rtspsrc protocols=tcp latency=100 location=rtsp:// ! rtph264depay ! h264parse ! nvv4l2decoder ! nvvideoconvert ! nv3dsink

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.