Help with viewing RTP stream from Jetson Nano to PC

I’m trying to set up my Jetson Nano 2GB (running latest JetPack) so that I can view the video stream output from my WIndows 10 laptop. I’ve been trying to use an sdp file in VLC but when I open the file nothing occurs. I have the port forwarded on my laptop.

Below is the code I’m executing in Jupyter Lab:

import jetson.inference
import jetson.utils

net = jetson.inference.detectNet(“ssd-mobilenet-v2”, threshold=0.5)
camera = jetson.utils.videoSource("/dev/video0")

display = jetson.utils.videoOutput(“rtp://<LAPTOP_IP>:”)
while display.IsStreaming():
img = camera.Capture()
detections = net.Detect(img)
display.Render(img)
display.SetStatus(“Object Detection | Network {:.0f} FPS”.format(net.GetNetworkFPS()))
print()
print(“loop completed”)

The sdp file contains:
c=IN IP4 192.168.0.
m=video RTP/AVP 96
a=rtpmap:96 H264/90000

I don’t know if I ought to be using a different way of viewing the output of the model/the webcam stream on my laptop, I’m pretty new to this and I’ve only just finished the into on github so I might be going down the wrong path altogether, any help is appreciated!

Sorry for the late response, is this still an issue to support?

Hi @s.coughlan15, it looks like this SDP file is incomplete, it is missing proper localhost IP address and port number. The IP in the SDP file should be your laptop’s localhost (127.0.0.1)

  c=IN IP4 127.0.0.1
  m=video 1234 RTP/AVP 96
  a=rtpmap:96 H264/90000

Also, specify the port in your detection script: display = jetson.utils.videoOutput(“rtp://<LAPTOP_IP>:1234”)

If you continue having problems with VLC, I recommend to try GStreamer to view the RTP feed - see here: https://github.com/dusty-nv/jetson-inference/blob/master/docs/aux-streaming.md#viewing-rtp-remotely

Hello @dusty_nv
I have a similar question regarding viewing RTP remotely.
I sshed into the jetson nano, and I tried a simple test to see if I can get the output on the pc but after creating an sdp file based on the github’s post directions and opening it on the pc I do not get anything.
content of the sdp file
c=IN IP4 127.0.0.1
m=video 1234 RTP/AVP 96
a=rtpmap:96 H264/90000
I have tried to run the following commands on the jetson
video-viewer --output-codec=h264 ~/output.mp4 rtp://127.0.0.1:1234
video-viewer --output-codec=h264 /dev/video0 rtp://127.0.0.1:1234
and after I run these commands I can see that frames are being captured on the jetson side but nothing is displayed on the PC side in VLC player
I was wondering if I am missing something?

I think the solution was to use a different ip address rather than 127.0.0.1
I used the broadcast ip address that I found via the ifconfig command in jetson from the eth0 and now I can view the input feed remotely on the PC host