High CPU usage of X and KWin on openSUSE Leap 42.2

Hello!

I have a problem on openSUSE Leap 42.2 with KDE Plasma 5.8 - there is high CPU usage when the animation before screen goes off is played (dimming the screen). This is happening sometimes even on other more complex animations of Plasma. I have tried various settings of the driver and the settings in the “Compositor” section in the KDE settings, but nothing happened. I have measured the CPU with top and found that X and KWin are loading heavily the CPU in this cases - and the most annoying - so heavily that there are audio glitches when music has being played.

System:
Fujitsu Celsius H710 with Intel Core I7 2760, 8 GB RAM, 8 GB swap, nVidia Quadro 1000M;
Software:
openSUSE Leap 42.2 with kernel 4.4.46-11, nVidia proprietary drivers 375.26, X Server 1.18.3, KDE Plasma 5.8.3, qt 5.6.1, Frameworks 5.26.0.

What should I do?

Hello again!

Two days ago I have updated to 375.39 version and everything now works fine but only with “specific configuration”:
-In KDE Plasma Compositor section - OpenGL 3.1 selected as backend and disabled tearing prevention;
-In NVIDIA X Settings, in the OpenGL section - “Sync to VBlank” and “Allow flipping” both disabled;
Only with this settings the performance is significantly better, no high CPU usage, smooth desktop effects, everything is fine. In every other configuration the problem remains.