High Memory leak , Quadro FX 380,

Hello ,

I am using a NVIDIA Corporation G96 [Quadro FX 380] on a Redhat WS running Kernel 2.6.32-358.6.2.el6.x86_64 . I am experiencing high memory leak on my system . Xorg uses the most memory as per top results for

/usr/bin/Xorg :3 -br -verbose -audit 4 -auth /var/run/gdm/auth-for-gdm-Bd3ojJ/database

I am including my current xorg configuration files for your reference

[root@fw03 ~]# cat /etc/X11/xorg.conf

nvidia-settings: X configuration file generated by nvidia-settings

nvidia-settings: version 319.17 (buildmeister@swio-display-x86-rhel47-06) Thu Apr 25 22:28:13 PDT 2013

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 0 0
Screen 1 “Screen1” 1600 0
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “1”
EndSection

Section “Files”
FontPath “/usr/share/fonts/default/Type1”
EndSection

Section “InputDevice”

# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/input/mice"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"

EndSection

Section “InputDevice”

# generated from data in "/etc/sysconfig/keyboard"
Identifier     "Keyboard0"
Driver         "keyboard"
Option         "XkbLayout" "us"
Option         "XkbModel" "pc105"

EndSection

Section “Monitor”

# HorizSync source: xconfig, VertRefresh source: xconfig
Identifier     "Monitor0"
VendorName     "Unknown"
ModelName      "CRT-1"
HorizSync       30.0 - 92.0
VertRefresh     48.0 - 85.0
Option         "DPMS"

EndSection

Section “Monitor”

# HorizSync source: edid, VertRefresh source: edid
Identifier     "Monitor1"
VendorName     "Unknown"
ModelName      "HP LP2065"
HorizSync       30.0 - 92.0
VertRefresh     48.0 - 85.0
Option         "DPMS"

EndSection

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “Quadro FX 380”
BusID “PCI:15:0:0”
EndSection

Section “Device”
Identifier “Device1”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “Quadro FX 380”
BusID “PCI:40:0:0”
EndSection

Section “Screen”

Removed Option “metamodes” “CRT: 1600x1200 +0+0, DFP: nvidia-auto-select +0+0; CRT: nvidia-auto-select +0+0, DFP: 1600x1200 +0+0; CRT: nvidia-auto-select +0+0; CRT: 1600x1200 +0+0; CRT: 1600x1200_65 +0+0; CRT: 1600x1200_60 +0+0; CRT: 1440x900 +0+0; CRT: 1440x900_75 +0+0; CRT: 1440x900_60 +0+0; CRT: 1440x900_60_0 +0+0; CRT: 1400x1050 +0+0; CRT: 1400x1050_60 +0+0; CRT: 1400x1050_60_0 +0+0; CRT: 1360x768 +0+0; CRT: 1280x1024 +0+0; CRT: 1280x1024_75 +0+0; CRT: 1280x1024_60 +0+0; CRT: 1280x960 +0+0; CRT: 1280x960_60 +0+0; CRT: 1280x800 +0+0; CRT: 1280x800_75 +0+0; CRT: 1280x800_60 +0+0; CRT: 1280x800_60_0 +0+0; CRT: 1280x768 +0+0; CRT: 1280x768_75 +0+0; CRT: 1280x768_60 +0+0; CRT: 1280x768_60_0 +0+0; CRT: 1152x864 +0+0; CRT: 1024x768_75 +0+0; CRT: 1024x768_70 +0+0; CRT: 1024x768_60 +0+0; CRT: 848x480 +0+0; CRT: 800x600 +0+0; CRT: 800x600_85_0 +0+0; CRT: 800x600_75 +0+0; CRT: 800x600_72 +0+0; CRT: 800x600_60 +0+0”

Removed Option “metamodes” “nvidia-auto-select +0+0; 1600x1200 +0+0”

Removed Option “metamodes” “CRT: nvidia-auto-select +288+216, DFP: nvidia-auto-select +0+0; DFP: 1600x1200 +0+0”

Removed Option “metamodes” “CRT: 1600x1200 +0+0, DFP: nvidia-auto-select +0+0; DFP: 1600x1200 +0+0”

Removed Option “metamodes” “CRT: 1600x1200_60 +0+0, DFP: nvidia-auto-select +0+0; DFP: 1600x1200 +0+0”

Removed Option “metamodes” “CRT: 1600x1200 +0+0, DFP: 1600x1200_60 +0+0; DFP: 1600x1200 +0+0”

Identifier     "Screen0"
Device         "Device0"
Monitor        "Monitor0"
DefaultDepth    24
Option         "Stereo" "0"
Option         "nvidiaXineramaInfoOrder" "DFP-0"
Option         "metamodes" "CRT: 1600x1200_60 +0+0, DFP: 1600x1200 +0+0; DFP: 1600x1200 +0+0"
SubSection     "Display"
    Depth       24
EndSubSection

EndSection

Section “Screen”
Identifier “Screen1”
Device “Device1”
Monitor “Monitor1”
DefaultDepth 24
Option “Stereo” “0”
Option “nvidiaXineramaInfoOrder” “DFP-1”
Option “metamodes” “DFP-0: nvidia-auto-select +1600+0, DFP-1: 1600x1200 +0+0”
SubSection “Display”
Depth 24
EndSubSection
EndSection

Section “Extensions”
Option “Composite” “Disable”
EndSection

Please let me know your valuable inputs how to fix this issue .

How fast does the memory usage build up? Does X also begin to use more and more CPU (even when nothing happens) when the memory usage rises?
On my notebook with Quadro FX 770M and Fedora 17, I have to restart Xorg every 2-3 working days because X uses a few hundred megs of RAM, about 10-20% CPU when idle and thunderbird becomes slower and slower, especially when scrolling.
xrestop does not indicate any high resource usage. I’m using KDE with desktop effects turned off.
On my desktop with a GTX 460 I’m seing the same, but the memory usage seems to rise much more slowly. Might be caused by differences in used programs (I suspect thunderbird, which I do not use on my Desktop).

Does the same memory usage increase occur with a different desktop environment? KDE is known to leak resources that show up as memory usage in the X server. There was an interesting analysis of its excessive resource usage recently: http://lists.x.org/archives/xorg-devel/2013-May/036332.html