hostid = 000000000000

I have installed the pgi except the license

[root@localhost pgilinux-117]# pgf77 -V x.f

pgf77 11.7-0 32-bit target on x86 Linux -tp core2
Copyright 1989-2000, The Portland Group, Inc. All Rights Reserved.
Copyright 2000-2011, STMicroelectronics, Inc. All Rights Reserved.
pgi-f77-lin32: LICENSE MANAGER PROBLEM: Failed to checkout license


but when I want to check my hostid

[root@localhost pgilinux-117]# lmutil lmhostid
lmutil - Copyright © 1989-2009 Acresso Software Inc. All Rights Reserved.
The FLEXnet host ID of this machine is “000000000000”

I’m sure the 000000000000 is not the correct one

but how to find the right hostid?

[root@localhost pgilinux-117]# lmutil lmhostid -display
lmutil - Copyright © 1989-2009 Acresso Software Inc. All Rights Reserved.
The FLEXnet host ID of this machine is “DISPLAY=/dev/pts/0”


How to solve this problem

Hello.

I suspect you either have no network cards, or you have a bridge
or tunnel causing the hostid to not be present.

Send the output of
/sbin/ifconfig

to trs@pgroup.com so we can look at it.

But, the bottom line is - if there is no 12 digit output other than
all zeros, all ones, or a blank, from

lmutil lmhostid

on your platform, there is no way to create a permanent license
for it. We have no alternative.

dave

Hello,

We just bought a PGI 12.2 Workstation License and I got the same problem, hostid with just zero.

Cold you please let me know what can I do to try to get this working?

thanks,
carlos

Hi Carlos,

Most likely you have the same issue as the original poster where no network adapter could be found. Please send the output of “/sbin/ifconfig” to PGI Customer Support (trs@pgroup.com) to see if it’s a simple system configuration issue.

  • Mat

hello guys,

I had the same problem, it seems to be related to the fact that
Flexlm tool finds a MAC addr of loopback interface which is 0:0:0:0:0

This is because starting from Fedora 15, there is a new naming convention
for network interfaces where eth0 is called pXpY which is not recognized by
flexlm tools. To use default naming, I set ‘biosdevname=0’ kernel parameter in grub2.cfg
(you can also erase /lib/udev/rules.d/71-biosdevname.rules file, if there is one).
After that lmutil correctly finds my network adapter.

Provided that this is a common problem for all poor Fedora users, maybe it makes
sense to include this into installation manual
instead of just solving this issue on individual bases ?

Hi wiener.b,

Thanks for the information. We have an open support ticket with Flexera, the makers of Flexlm, regarding this problem and hope to have it addressed soon.

Best Regards,
Mat

I have similar problems with Rocks6 (CentOS 6) and Dell R720 nodes!!!
The ethernet interface are named emX and so flexnet hostid is 00000000…

Can you help me?


PS : i can t reboot the cluster…

Linux versions that configure network cards as em0 or em1 have this problem.

It should be corrected with the 13.1 release, which uses new flexlm utils.

Change the
configuration to something like ‘eth0’. An example of this is found at
http://www.sysarchitects.com/em1_to_eth0 .