Hostpot wifi error

Hi!

I can’t create a hotspot with the tx2’s built-in wifi card. Here is my configuration:
Install the dependencies :

$ sudo apt-get install dnsmasq haveged hostapd build-essential util-linux procps iproute2 iw haveged

To install create_ap run:

$ git clone https://github.com/oblique/create_ap
$ cd create_ap
$ sudo make install

enable/start/status the service:

$ sudo systemctl enable create_ap.service
$ sudo systemctl start create_ap.service
$ systemctl status create_ap

To create your access point run without service:

$ sudo create_ap wlan1 eth0 hotspot-test password1111

I have try this configuration with an USB dongle wifi and I haven’t had any problems, it’s working fine.

Here are the logs :
dmesg:

[jeu. févr. 27 14:22:39 2020] Register interface [ap0]  MAC: 02:04:4b:de:36:47
[jeu. févr. 27 14:22:39 2020] [02-27 13:22:39.924] wl_cfg80211_add_virtual_iface:  virtual interface(ap0) is created net attach done
[jeu. févr. 27 14:22:39 2020]  dhd_cfg80211_set_p2p_info :
[jeu. févr. 27 14:22:39 2020] Set : op_mode=0x0005
[jeu. févr. 27 14:22:41 2020] nf_conntrack version 0.5.0 (65536 buckets, 262144 max)
[jeu. févr. 27 14:22:41 2020]  wl_cfg80211_del_station :
[jeu. févr. 27 14:22:41 2020] Disconnect STA : ff:ff:ff:ff:ff:ff scb_val.val 3
[jeu. févr. 27 14:22:41 2020]  check_dev_role_integrity :
[jeu. févr. 27 14:22:41 2020] device role select failed

create_ap:

févr. 27 14:22:39 nip create_ap[7378]: Config dir: /tmp/create_ap.wlan0.conf.8zAUttC9
févr. 27 14:22:39 nip create_ap[7378]: PID: 7378
févr. 27 14:22:39 nip create_ap[7378]: Network Manager found, set ap0 as unmanaged device... DONE
févr. 27 14:22:42 nip create_ap[7378]: Creating a virtual WiFi interface... ap0 created.
févr. 27 14:22:42 nip create_ap[7378]: No Internet sharing
févr. 27 14:22:42 nip dnsmasq[7680]: started, version 2.79 cachesize 150
févr. 27 14:22:42 nip dnsmasq[7680]: compile time options: IPv6 GNU-getopt DBus i18n IDN DHCP DHCPv6 no-Lua TFTP conntrack ipset auth DNSSEC loop-detect inotify
févr. 27 14:22:42 nip dnsmasq-dhcp[7680]: DHCP, IP range 10.0.0.1 -- 10.0.0.254, lease time 1d
févr. 27 14:22:42 nip create_ap[7378]: hostapd command-line interface: hostapd_cli -p /tmp/create_ap.wlan0.conf.8zAUttC9/hostapd_ctrl
févr. 27 14:22:42 nip dnsmasq[7680]: reading /etc/resolv.conf
févr. 27 14:22:42 nip dnsmasq[7680]: using nameserver 127.0.0.1#53
févr. 27 14:22:42 nip dnsmasq[7680]: cleared cache
févr. 27 14:22:42 nip create_ap[7378]: Configuration file: /tmp/create_ap.wlan0.conf.8zAUttC9/hostapd.conf
févr. 27 14:22:42 nip create_ap[7378]: Using interface ap0 with hwaddr 02:04:4b:de:36:47 and ssid "hotspot-test"
févr. 27 14:22:42 nip create_ap[7378]: ap0: interface state UNINITIALIZED->ENABLED
févr. 27 14:22:42 nip create_ap[7378]: ap0: AP-ENABLED

My test to see if the card manages to use the wifi card in scan:

$ sudo iwlist wlan0 scan | grep -i ssid
                    ESSID:"Bbox-*********"
                    ESSID:"*********-2.4G"
                    ESSID:"Bbox-*********"
                    ESSID:"freebox*********"
                    ESSID:"FreeWifi*********"
                    ESSID:"FreeWifi*********"
$ sudo iwlist wlan0 scan | grep -i "ghz"                                                                                                                                                            
                    Frequency:2.462 GHz (Channel 11)
                    Frequency:2.412 GHz (Channel 1)
                    Frequency:5.22 GHz (Channel 44)
                    Frequency:2.412 GHz (Channel 1)
                    Frequency:2.462 GHz (Channel 11)
                    Frequency:2.462 GHz (Channel 11)
                    Frequency:2.462 GHz (Channel 11)
                    Frequency:2.437 GHz (Channel 6)
                    Frequency:2.437 GHz (Channel 6)

Thank you in advance.

no one? :/

Hi,

Sorry for late reply.

By default, ubuntu is using networkmanager to enable wifi AP now. We haven’t used hostapd to enable wifi for a long time.

Could you try to use networkmanager instead?

Hi, @omegaBionic
Typically it requires to select “share connection to other computers” to enable the hotspot mode
I also used https://docs.ubuntu.com/core/en/stacks/network/wifi-ap/docs/basic-ap-setup as I can recollect

references:




http://variwiki.com/index.php?title=Wifi_NetworkManager

Hi everyone,

Thank you very much for your help!

I’m testing this as soon as I can, but under the current conditions it could take a while.