How can I find the firmware version?

How can I find the firmware version on a MHGH28-XTC card? I’m pretty sure I’ve seen the command for Linux but not for a windows machine.

the spec looks right but it doesn’t say those were design for InfiniBand so I can’t tell you for sure it will work.

specifically search for “infiniband CX4 copper cables”

Should I assume a problem with the card if vstat.exe doesn’t work?

Do you have WinOF installed? You can use vstat.exe

What’s the problem you are having?

yeah i got these ones on ebay, but like I said they didn’t fit.

1m 28AWG External SAS 34pin (SFF-8470) M to SAS 34pin (SFF-8470) M Cable - Black

Ill check for cx4 cables… they should snap in from the likes of the card.

I took off the “brackets” at both ends and plug them in, shouldn’t it have worked its the same (SFF-8470) as I’m finding for the cx4 cables?

Hi Marc,

i am following up on this post. were you able to fix your card?

See my other topic … I can’t access the card no firmware updates nothing … no lights … windows error code 10

run opensmd (OpenSM Daemon) on one of the machines and then assign static addresses.

I say bump this note into that topic, and have Yair continue. Sounds like your card might be bricked as I think he was stating. Can you put it into a different server or PCIe slot to check?

Thanks, not sure how I would have bricked it since it never worked. I’ve tried it in two machines and six different pcie slots and always the same result.

Any suggestions where I can get a cx4 cable? I have opensm running on one but with the wrong cables, guess it won’t work

Sent from Mailbox for iPhone

I was able to update the firmware on them, so windows recognizes them

properly. However based on this person’s blog I thought I would be able to

go server to server using the cable and just assigning straight IPs on a

different subnet but that didn’t work, the cards are showing up as

disconnected. I’m also thinking I bought the wrong cable because the

connector is different. I had to remove the brackets at both ends just to

plug them into the cards.

Hi Marc,

well-done!

if you connect two servers one to each other or more servers via a switch, one of the servers or the switch itself (if this is a managed version) must run a component called OpenSM. without it your network will not come up.

just login into one of your servers and from the command-line run opensmd and keep it running. that should take care of things.

as for the cable, there are few connector types. CX4 used for DDR and older cards and QSFP for QDR and newer cards. the card you have (MHGH28-XTC) is a DDR and therefore you will need a CX4 cable.

i hope it help… let me know if you need more info.

You can get it from Mellanox or find on-line. Since this is the previous generation I imagine it will be fairly cheap.

this one doesn’t look like a complete CX4 cable. it meant more for SAS systems and might have different pinout arrangement.

Get an Infiniband cable rate for DDR speeds with CX4 connectors.

All should be right there: Mellanox Products: Mellanox OFED for Windows (WinOF) http://www.mellanox.com/page/products_dyn?product_family=32&mtag=windows_sw_drivers

yairi https://community.mellanox.com/s/profile/005500000015XiPAAU

Sorry if i’m a pain, I found these, do they look like the right ones?

Premium CX4 to CX4 http://www.infinitecables.com/pop/ms-300-m.htm

I took a stab and ordered them, worst case I’ll return them. If I’m correct all I’d have to do is assign static IPs and I should be ok?

Could you point me in the direction of any windows docs for this? Opensm is running as a service on the machine … not familiar with the daemon