How can I flash jetpack 4.2.2 to my TX2?

tx2 boot-up log.txt (86.6 KB)

I have copied it over putty. not selecting the text but just right click to the header and select copy all to clipboard function. then past it to notepad ++ and save it as txt. its showing good in notepad in windows.

reminder for previous steps:
I have a tx2 not functioning properly and wanted to fix it by cloning from another functioning one. This way I would be able to keep all services and apps running properly. I dont have chance to install them from scratch.

As I understand from other people’s posts I need to have same version of jetson of master in the copy to make it working properly. Because of that I have flashed the new TX2 with same jetpack version over a linux machine with SDK manager. Flash was successful and I was able reach to the clean TX2 interface.

Then I have clone the APP part of master TX2 with below command,
sudo ./ -r -k APP -G backup.img jetson-tx2 mmcblk0p1

then copied the img file to bootloader,
sudo cp backup.img.raw bootloader/system.img

and connect the new TX2 to copy APP to it
sudo ./ -r -k APP jetson-tx2 mmcblk0p1

Then I received error on bootscreen
FAILED : Failed to mount /var/log
DEPEND: Dependency failed for local file systems

Couldnt move further yet.


I just want to double confirm,

  1. So this TX2 problematic device could be flashed by pure sdkmanager jetpack4.2.2?

  2. Is the “master TX2” also using a jp4.2.2?

I need to correct something on the versioning. Its 4.2.1.

  1. Yes, it can be flashed with 4.2.1 and I could reach to its interface.
  2. yes, it is 4.2.1


I have more things to clarify here.
To make it easier to tell, I will name your problematic TX2 as TX2-NG and master TX2 as TX2-M.

Are you sure the TX2-NG was previously flashed with jp4.2.1 before you did the clone? Just a reminder that “-r -k APP” will not flash the whole board, it will just flash the APP partition.

From what I saw, your device tree running on TX2-NG is based on rel-32.5. I guess it should be rel-32.5 unless you have some weird naming to name a 32.2.1 kernel with rel-32.5 name…

[ 0.181801] DTS File Name: /home/sjx/32.5.0_code/code/kernel/kernel-4.9/arch/arm64/boot/dts/…/…/…/…/…/…/hardware/nvidia/platform/t18x/quill/kernel-dts/tegra186-quill-p3310-1000-c03-00-base.dts

I was sure until you told this :) what I ll do is to flash TX2-NG again with jp4.2.1 from sdk manager and share screenshots as well.
I ll update in here.

Thanks for helping.

The log is actually ok, but hard to read because it has a forced line wrap. This might be a feature of the serial console program being used. Turning off line wrap at a specific column would solve that and make reading easier (the person viewing would then be where line wrap is chosen). Or you could perhaps tell it to wrap about 30 columns further to the right.

I noticed some i2c errors. Is the device tree correct for that carrier board’s i2c items?

Hi @linuxdev , thanks for comment. How can I check the device tree is correct or not? May master tx2 logs from serial port helps?

Regarding device tree, if you flashed an actual dev kit (not a third party carrier board) with the software provided from NVIDIA, then this would be likely the correct device tree. If there is any third party carrier board involved, and the flash software was not from the third party supplier, then device tree is likely wrong. You would need to state what specific carrier board this is (in terms of if it is a dev kit versus third party), and whether it has been flashed (if flashed, then where the software was from). Most incorrect device trees are from installing from the wrong flash software versus the device the software was intended for.

1 Like

I have realized the v32.5 mark in the logs @WayneWWW mentioned is because of the dtb patch I used sent from the carrier board company. Its not matching with the v32.2.1 installed in the TX2. It may be the reason of device tree problems @linuxdev mentioned.
I have asked the company a version of dtb patch for v32.2.1
I ll update you guys here.

Hi guys,
I have reflashed the TX2-NG with Jetpack 4.2.2 (R32.2.1) with sdk manager. Received another DTB file from the carrier board company for this version and flashed it with below code

sudo ./ -k kernel-dtb jetson-tx2 mmcblk0p1

After flashing this USB connection start working and I was able to continue installation. SDK manager gave a couple of errors while installing opencv etc. you may see below screenshot.

Then I have finalized installation with these errors. TX2-NG interface is reachable and usable. But I have received some errors from serial port as you may see attached. (all above actions before cloning the TX2-M, I ll continue cloning after this) do you have any suggestion till now?

tx2-ng-log.txt (52.9 KB)


So is the desktop GUI able to work fine now with this setup or not?

Also, your kernel log is not included in the uart log. Please either removing quiet from kernel cmdline or just use command dmesg and share the log.

I havent cloned TX2-M yet. This logs from newly flashed TX2-NG.
I have added the logs from dmesg command.

dmesglog.txt (79.8 KB)

I’ll clone the TX2-M if you say these errors are normal.

Why you answered a weird answer to me here? Why “desktop GUI is working or not” related to cloning?

Because my problem with GUI is after cloning. It is working well just after re-flashing. No problem with that.

But when I clone the master tx2 I am getting error as I explained above.

Yes, I just need your answer about your pre-cloning situation.

Now you can test you cloning, please go ahead.

I have cloned again with below command

sudo ./ -r -k APP jetson-tx2 mmcblk0p1

But it gives same error. you may find the log below.
tx2-ng-log.txt (88.2 KB)

Is there any way to clone not only APP but also kernel etc. other possible units? May it help to solve?


Honestly, 4.2.2 is a very old one. So I am not sure if bootloader update mechanism is properly working then.

May I ask why not just upgrading your jetpack version?

Also, want to ask one point here. Does the data on TX2-M really matter? I just want to make an experiment that if you do the reversed direction of cloning, what would happen on TX2-M?

I mean

  1. Reflash your TX2-NG to back with sdkmanger. And reflash the board again with the dtb provided by vendor.

  2. Clone the image from TX2-NG to your TX2-M.

  3. Check if TX2-M hit same “Press Enter for maintenance” log in serial console.

Unfortunately it’s important to keep the data in TX2-M. The data and services running in there was installed by a company but we have no reach to them currently.
But I can tell you a mistake I did earlier to fix this issue may help. I got backup from a working tx2 and restore this backup to same tx2 by mistake. It gave same error. I think one of the non working tx2s is that one.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.