How can I improve the performance of simulation?

Hi, I’m doing a simulation include lots of collision detection. But I found that there were sometimes unstable motion when collision detected (the object was jittering). How can I improve the performance of simulation?

1 Like

Without looking at your specific use case, it could be many factors.
Are you using the correct gravity/unit (cm vs m)?
Also try setting your physics scene’s BroadPhase to MBP instead.
Do they fall and sleep fine but only jitter when they are about to collide? Tune/Reduce the collision shapes’ collision offset.
https://docs.omniverse.nvidia.com/prod_extensions/prod_extensions/ext_physics.html?highlight=tuning#collision-shape-settings

You can also connect to PVD running on Windows. The PVD connection is under Window\Physics\Settings\PVD

Hi @HaiLocLu ,
Thanks for your reply!
My scenario is that I control a manipulator (UR10) to do a peg-in-hole task.

  1. I’m using the correct gravity.
  2. Yes, they fall and sleep fine but only jitter when they are colliding. My collision offset setting is

physxCollision: contactOffset: 0.001
physcCollision:restOffset: 0.000

Is there any other parameters about collision that I can tune?
3. I’m using Issac Sim on Ubuntu. But PVD doesn’t support Ubuntu

Right, PVD will need to run on Windows and you specify its IP address in the PVD connection tab from your Ubuntu.

But try reducing the contactOffset for both the peg and the hole. Also reduce peg’s Property Window/Rigid Body/Advanced/Max Depenetration Velocity and Contact Impulse. Increase the Solver Iteration counts to something big like 32, etc. The idea is to reducing the contacts pushing each other out.

Where can I modify the Solver Iteration counts?
Are there solverPositionIterationCount and solverVelocityIterationCount?
And I try to using PVD connect on ubuntu. But it keeps showing Reconnect PVD. How can I connect to PVD

Yes, those solverPositionIterationCount and solverVelocityIterationCount.
Did you specify your Windows IP from the Isaac Sim running on Linux? In this case, i think trying to tune those physics parameters might help.

After tuning these parameters, it improves a lot. Thanks!