How can I install tensorflow on jetson tk1

I want to install tensorflow on jetson tk1?
I saw the others topic and answer and tried to follow next two links but I the errors appear.


https://github.com/Lisandro79/JetsonCaffe/wiki/Install-Tensorflow-on-TK1

and the error appear when I install bazel.

ERROR: /home/ubuntu/bazel/src/main/java/com/google/devtools/common/options/BUILD:6:1 Java compilation in rule ‘//src/main/java/com/google/devtools/common/options:options’ failed: java failed: error executing command external/local-jdk/bin/java -Xbootclasspath/p:external/bazel_tools/third_party/java/jdk/langtools/javac.jar -client -jar bazel-out/host/bin/src/java_tools/buildjar/bootstrap_deploy.jar … (remaining 1 argument(s) skipped): Worker process did not return a correct WorkResponse. This is probably caused by a bug in the worker, writing unexpected other data to stdout.
Target //src;bazel faild to build
Use --verbose_failures to see the command lines of failed build steps.

Hi,

It’s NOT recommended to use TK1 for deep learning use case.
The latest available cuDNN is version 2.0 and this will give you lots of limitation especial for deep learning.

To compile TensorFlow on TK1, please remember to check all the dependency version is compatible with TK1 first.
Thanks.

Thank you for quick answer.

I understand the TK1 is not good at deep learning.
But can I ask you why that error appear?

Of course it’s not a latest version. But the others install the tensorflow and I don’t have enough time to buy new model…

Hi,

A possible cause is that the compiling worker get stuck since lack of resource.
Add more swap space may help.

Thanks.

Hi,

Did you manage to get it working? If so some help would be much appreciated! I have also been trying to use Tensorflow or Pytorch on the TK1, so far unsuccessfully!

Thanks!

hello,

I have tried before, the method comes from the follow website:
https://blog.csdn.net/qq_37631344/article/details/77984991

steps as follow:
0. sudo apt-get install git

  1. git clone https://github.com/dat-ai/tensorflow-on-nvidia-jetson/
  2. cd tensorflow-on-nvidia-jetson
  3. sudo apt-get install python-pip
  4. sudo pip install tensorflow-0.8.0-py2-none-any.whl
  5. test tf in python, like “import tensorflow as tf”

With the support from nvidia, Jetpack includes some basic tools like cuda, cudnn and so on.
But, following the steps in the website, the version of tf is just 0.8.0.
I have tried to upgrade version, but failed.
I have tried a simple example with a light CNN, the result is bad.
so… I give up, TK1 seems to be good at encode and decode for video and audio, like opencv.

The only good news is that I didn’t meet any strange error during installation. If the version is OK, you could have a try, good luck!

Hi,

Thanks for your reply. For me when I run the 4th step on the TK1 I get the following error:

tensorflow-0.8.0-py2-none-any.whl is not a supported wheel on this platform.

Thanks

I try it again, everything is working fine.
Did you have installed python-wheel? Try “sudo apt-get install python-wheel”
OR Make sure python version is 2.7

Hope it will work…

Hi,

Yes using Python 2.7 worked for me! Thank you! Although now when trying to “import tensorflow as tf” I get a Cuda error. I think this is because cuda was installed using Python 3… Does this make sense?

Thanks again!

Hi, When I run “import tensorflow as tf”
shows me below error which stated that unable to load cuDNN DSO?

I tensorflow/stream_executor/dso_loader.cc:105] successfully opened CUDA library libcublas.so locally
I tensorflow/stream_executor/dso_loader.cc:99] Couldn’t open CUDA library libcudnn.so. LD_LIBRARY_PATH: /usr/local/cuda-6.5/lib:/usr/local/cuda/lib:
I tensorflow/stream_executor/cuda/cuda_dnn.cc:1562] Unable to load cuDNN DSO
I tensorflow/stream_executor/dso_loader.cc:105] successfully opened CUDA library libcufft.so locally
I tensorflow/stream_executor/dso_loader.cc:105] successfully opened CUDA library libcuda.so.1 locally
I tensorflow/stream_executor/dso_loader.cc:105] successfully opened CUDA library libcurand.so locally

CAN YOU PLEASE RECTIFY THIS ERROR