How can I send it to another host VLC using aurducam 12MP IMX477 webcam?

Hello everyone,
I’m going to link a webcam called imx477 to Jetson Nano and run vlc on another host computer for real-time streaming.

First, I got the exclusive library for Ardu Cam and installed it. The screen worked fine.
(IMX477 - PTZ Camera - Arducam)

However, there was a problem with the real-time streaming that I tried for the second time.
(FFmpeg를 사용하여 웹캠 영상과 동영상 파일을 RTSP 스트리밍하기(RTSP streaming webcam / video files using FFmpeg) - 멈춤보단 천천히라도)

On that site, the camera format format is YUYU, mpeg, while I came out in RG10 format.

$ v4l2-ctl --list-formats-ext
        Index       : 0
        Type        : Video Capture
        Pixel Format: 'RG10'
        Name        : 10-bit Bayer RGRG/GBGB
                Size: Discrete 4032x3040
                        Interval: Discrete 0.033s (30.000 fps)
                Size: Discrete 3840x2160
                        Interval: Discrete 0.033s (30.000 fps)
                Size: Discrete 1920x1080
                        Interval: Discrete 0.017s (60.000 fps)

I’ve been looking for ways to run the code in RG10 format.

$ ffmpeg -f v4l2 -list_formats all -i /dev/video0
ffmpeg version 3.4.8-0ubuntu0.2 Copyright (c) 2000-2020 the FFmpeg developers
  built with gcc 7 (Ubuntu/Linaro 7.5.0-3ubuntu1~18.04)
  configuration: --prefix=/usr --extra-version=0ubuntu0.2 --toolchain=hardened --libdir=/usr/lib/aarch64-linux-gnu --incdir=/usr/include/aarch64-linux-gnu --enable-gpl --disable-stripping --enable-avresample --enable-avisynth --enable-gnutls --enable-ladspa --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libmp3lame --enable-libmysofa --enable-libopenjpeg --enable-libopenmpt --enable-libopus --enable-libpulse --enable-librubberband --enable-librsvg --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxml2 --enable-libxvid --enable-libzmq --enable-libzvbi --enable-omx --enable-openal --enable-opengl --enable-sdl2 --enable-libdc1394 --enable-libdrm --enable-libiec61883 --enable-chromaprint --enable-frei0r --enable-libopencv --enable-libx264 --enable-shared
  libavutil      55. 78.100 / 55. 78.100
  libavcodec     57.107.100 / 57.107.100
  libavformat    57. 83.100 / 57. 83.100
  libavdevice    57. 10.100 / 57. 10.100
  libavfilter     6.107.100 /  6.107.100
  libavresample   3.  7.  0 /  3.  7.  0
  libswscale      4.  8.100 /  4.  8.100
  libswresample   2.  9.100 /  2.  9.100
  libpostproc    54.  7.100 / 54.  7.100
[video4linux2,v4l2 @ 0x5590719640] Raw       : Unsupported : 10-bit Bayer RGRG/GBGB : 4032x3040 3840x2160 1920x1080
/dev/video0: Immediate exit requested

However, we are unable to find any way because of the error that the format does not support.

Is my camera not compatible with v4l2? What should i do now?

Looks like it’s not webcam to run the ffmpeg.
It looks like CSI camera. Have confirm with v4l2-ctl --all

Thank you, Moderator

I found a post about csi - camera rtsp. I’ll do it and leave the results.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.