How can I unlock fastboot on Shield TV?

Just picked up a shield TV from the nVidia store and booted it into fastboot mode, it’s plugged into my PC and recognized fine by fastboot, showing its serial number + fastboot when using “fastboot devices”.

I cannot however perform any fastboot commands. They all result in:

FAILED (command write failed (Unknown error))

Is there something I need to do to enable fastboot write permissions?

I’ve tried different ports, cables, computers, etc.

Nevermind, I found out that I had to set the system up and enable developer options first, then enable ADB debugging to get into fastboot using adb reboot bootloader.
Using the 3 second touch method to get into fastboot just results in a read-only bootloader for me.
I guess this is just a weird bug with just my device.

adb reboot bootloader -> working fastboot
3 second touch into fastboot -> fastboot refuses commands

fastboot oem unlock works now.

I think I’m going to RMA the Shield TV, it’s incredibly buggy. I’ve already issued oem unlock though, wonder if it will still be accepted…
WiFi disconnects every 10 seconds for 3 seconds or so, and when opening apps and navigating menus it sometimes goes to sleep.

Hey jcadduono !

On your shell

  • Just check that your shield is linked to your PC using “fastboot devices”, as you did before
  • Run the command “fastboot oem unlock” to unlock your bootloader
  • if it always fails, try running your commands using root permissions

You also can see all the fastboot options available running the command “fastboot” or “fastboot -h”