How can I use tlt-augment

Hey guys,I got my tlt docker installed and have a critically imbalanced dataset, so I need do some dataset augmentation. I tried to use the command ‘tlt-augment’ in the docker and jupyter notebook, but both of them doesn’t work. It’s end up with’ command not found’. I knew it from ‘Integrating TAO Models into DeepStream — TAO Toolkit 3.22.05 documentation’. Is it removed or I need to do some extra installition? Or I heard that add the augment config might be work, can someone provide me more detail? Thanks a lot.

It’s end up with’ command not found ’.

Could you please share the full command and full log?

Hi, here it is

I open the jupyter notebook


and can find the command.

Please check if you can.

Sorry we didn’t found it. Where is the directry “notebooks”, is it in the docker /workspace/ ?

Did you use the latest TLT docker 2.0_py3? If yes, after triggering the jupyter notebook, you will find the examples/augment/augment.ipynb

I was using tlt docker 2.0 py2. Is it too old? I’m pulling the new one

Hi, the problem solved. I downloaded the newest tlt docker, and the command is functioning. Thanks a lot!

1 Like