How can use multi cameras with DeepStream2.0 ?

Now, I can running deepstream with one ip camera. And it works well.
You can see code at :
https://blog.csdn.net/quantum7/article/details/82151637

When I use multi cameras, app exits with errors.
Anyone work with this case ? And what should I do to make it work ?

Thanks very much !

Hi, quantum6
We do support Multi rtsp cameras on Deepstream 2.0 for x86 version, you can try below config(just one slice clip) for multi rtsp cameras with original deepstream app,

[source0]
enable=1
#Type - 1=CameraV4L2 2=URI 3=MultiURI
type=2
uri=rtsp://10.24.216.167/media/video1
num-sources=1
gpu-id=0
[source1]
enable=1
#Type - 1=CameraV4L2 2=URI 3=MultiURI
type=2
uri==rtsp://10.24.216.243/media/video1
num-sources=1
gpu-id=0

modify the uri to yours, and run

/path to DeepStream_Release/usr/bin/deepstream-app -c “your configuration file path”

Thank U very much!
I modified as this:

[tiled-display]
enable=1
rows=2
columns=2
width=1280
height=720
gpu-id=0

[source0]
enable=1
#Type - 1=CameraV4L2 2=URI 3=MultiURI
type=3
uri=rtsp://admin:GH123@192.168.8.88:554
num-sources=4
gpu-id=0

And it works well!
Thank amyc!

which card are you using ? how many models do you inference

Hi
we are using Tesla p4, and you can find config from /path to sample/samples/configs/deepstream-app/source30_720p_dec_infer-resnet_tiled_display_int8.txt, that use 1 model, paste one clip here:

[primary-gie]
enable=1
gpu-id=0
net-scale-factor=0.0039215697906911373
model-file=…/…/models/Primary_Detector/resnet10.caffemodel
proto-file=…/…/models/Primary_Detector/resnet10.prototxt
model-cache=…/…/models/Primary_Detector/resnet10.caffemodel_b30_int8.cache

and from /path to sample/samples/configs/deepstream-app/source4_720p_dec_infer-resnet_tracker_sgie_tiled_display_int8.txt
that use 4 models,

[primary-gie]
enable=1
gpu-id=0
net-scale-factor=0.0039215697906911373
model-file=…/…/models/Primary_Detector/resnet10.caffemodel
proto-file=…/…/models/Primary_Detector/resnet10.prototxt
model-cache=…/…/models/Primary_Detector/resnet10.caffemodel_b4_int8.cache
labelfile-path=…/…/models/Primary_Detector/labels.txt
int8-calib-file=…/…/models/Primary_Detector/cal_trt4.bin

[secondary-gie0]
enable=1
net-scale-factor=1
model-file=…/…/models/Secondary_VehicleTypes/resnet18.caffemodel
proto-file=…/…/models/Secondary_VehicleTypes/resnet18.prototxt
model-cache=…/…/models/Secondary_VehicleTypes/resnet18.caffemodel_b16_int8.cache
mean-file=…/…/models/Secondary_VehicleTypes/mean.ppm
labelfile-path=…/…/models/Secondary_VehicleTypes/labels.txt
int8-calib-file=…/…/models/Secondary_VehicleTypes/cal_trt4.bin

[secondary-gie1]
enable=1
net-scale-factor=1
model-file=…/…/models/Secondary_CarColor/resnet18.caffemodel
proto-file=…/…/models/Secondary_CarColor/resnet18.prototxt
model-cache=…/…/models/Secondary_CarColor/resnet18.caffemodel_b16_int8.cache
mean-file=…/…/models/Secondary_CarColor/mean.ppm
labelfile-path=…/…/models/Secondary_CarColor/labels.txt
int8-calib-file=…/…/models/Secondary_VehicleTypes/cal_trt4.bin

[secondary-gie2]
enable=1
net-scale-factor=1
model-file=…/…/models/Secondary_CarMake/resnet18.caffemodel
proto-file=…/…/models/Secondary_CarMake/resnet18.prototxt
model-cache=…/…/models/Secondary_CarMake/resnet18.caffemodel_b16_int8.cache
mean-file=…/…/models/Secondary_CarMake/mean.ppm
labelfile-path=…/…/models/Secondary_CarMake/labels.txt
int8-calib-file=…/…/models/Secondary_CarMake/cal_trt4.bin

Are you using a HaiKang camera?
my application run purely slow (0.5 frame/s),
can you share your config file here.