How can we import gpio pins of jetson nano 2gb on jupiter notebook

how can we import gpio pins of jetson nano 2gb on jupiter notebook.?


This looks like Jetson related. We are moving this post to Jetson forum to get better help.

Thank you.

please refer to this Python library that enables the use of Jetson’s GPIOs,

i have already installed these libraries mentioned in GitHub but when I try to import these libraries in Jupiter it shows me the following error

hello 180456,

the Jetson GPIO library provides all public APIs provided by the RPi.GPIO library.
had you complete the installation? did you use pip or you cloned the repository to install that manually?

After following GitHub - NVIDIA/jetson-gpio: A Python library that enables the use of… 1 Accessing the GPIO pins on Jupiter notebook is now a piece of cake but i am stuck at 1 place that HOW TO ACCESS THE GPIO PINS ON "DOCKER CONTAINER JUPYTER NOTEBOOK".All the steps are being followed as same as this:
Jetson AI Fundamentals - S1E3 - Image Classification Project - YouTube
but no fruitful result is basically gives us the error of

Now what to do?Need Help!


could you please have a try to import the Jetson.GPIO module by using import Jetson.GPIO as GPIO.

I also tried importing GPIO as GPIO using Jetson.GPIO syntax import But it keeps giving me same error

hello 180456,

this should due to Jetson-GPIO not working on Python inside the container,
please check this topic to customized Jetson.GPIO for Nano.

I did my utmost efforts to resolve the issue of importing GPIO pins on docker Jupiter Notebook. I’ve been trying for it from last couple of days but couldn’t find an appropriate solution.
I’ve run multiple commands have tried to create permissions for other user, followed github commands, and the one’s recommended on developer forums but couldn’t earn an edge.
Here is the list of the errors I’ve been getting.

hello 180456,

could you please narrow down the issue,
are you able to using gpio lib from python shell (not from notebook) within container?
furthermore, are you able to access gpio lib using python shell without container?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.