How do I change the boot mode of JetsonXavierNX device?

My device is a Jetson XaviernX-16G EMMC (and a 128G SSD), can I change the boot mode? Currently, the device starts on SSD (the root directory is mounted to /dev/nvme0n1p1). I want to start on EMMC (the root directory is mounted to /dev/mmcblk0p1). Can I run a command to start the device? Or any other way
Thanks

If there are two boot entries in “/boot/extlinux/extlinux.conf”, then you can pick among them via serial console during boot. If you wish to use two entries, and change which one is default, then you’d use the same extlinux.conf file, edit the entry you want to be default, and possibly put it at the start of the entries (there is a bug in some releases where the first entry is default even if the default spec goes to a different entry).

1.Root from the SSD:
image

2.View the extlinux. conf file in the mounted MMC device
xx@ubuntu:/$ sudo mount /dev/mmcblk0p1 /mnt/
xx@ubuntu:/$ vim /mnt/boot/extlinux/extlinux.conf
image

3.My OBC file configuration
/dts-v1/;
/ {
compatible = “nvidia,cboot-options-v1”;
boot-configuration {
/* nvme boot-order can be in “nvme:C”, “nvme:pcie@”, or “nvme” format */
boot-order = “emmc”, “sd”, “usb”, “nvme”, “net”;

3.1 Update to the target board:
convert the DTS to a DTB:
dtc -I dts -O dtb -o cbo.dtb cbo.dts
./flash.sh -k CPUBL-CFG --image bootloader/cbo.dtb jetson-xavier-nx-devkit-emmc mmcblk0p1

However, when I reboot, the rootfs is still booted from SSD.
Am I doing it right? Is something wrong?

I tried to migrate the system from EMMC to USB (as an upgrade disk), and this problem occurred when I was migrating from USB to SSD. In addition, the following problem also arises.
image

Can I fix this by resetting the default Settings? How do I reset it?
Thank you

reboot” likely requires using “sudo reboot”. I use “sudo shutdown -r now” to reboot, or “sudo shutdown -h now” to halt. As a test, does “sudo ls” work?

There two possible extlinux.conf files. One is in the eMMC or SD card (depending on which Jetson model), the other is the external device (the SSD). Just to be certain, did you edit both (only one is needed, but if you get both, then you know it isn’t using the “wrong” one)?

Just to emphasize, the flashed DTB partition itself is not always used. If it is, I’m not sure about the priority of devices (someone else will have to answer that).