How do I disable GL_ARB_multitexture using environment variables to fix [Half-Life] overbright issue?

As it currently stands, playing Half-Life today without any tweaking has some very ugly lights that just wash out every-color the light supposed to have in the first place. Ever since I was obsessed with that issue; I have been trying to find a way to fix this and I found that this issue is caused with an OpenGL extension called GL_ARB_multitexture that, as I best undestand screws with the way the lighting is layered and it only does it with one pass.

I’ve seen a similar way to disable the problematic extension over at PCGamingWiki using environment variables, but that’s not for Nvidia users. And I was in the mindset that “there should be a way to do this similarly in Nvidia as well, right?” and I’ve tried searching for a documentation on how I could disable OpenGL extensions using environment variables for Nvidia cards. So much so I discovered the documentation site for the Non-Nvidia method, that I quickly cited because It wasn’t cited on PCGW.

However I have not found any of that yet, and I kinda grew tired of the search, so I was willing to create a new topic to see if more experienced people here know of a way to disable OpenGL extensions. If any of you know how I could do that, I thank you sincerely. Not only would this help me not go insane over this minuscule lighting detail issue I’ve noticed, but I’m willing to think there are more like me who wish they could easily disable this extension.