How do I increase the Deepstream app's display stream performance (FPS)?

• Hardware Platform (Jetson / GPU): Jetson AGX Xavier
**• DeepStream Version:**6.1
**• JetPack Version (valid for Jetson only):**5.0-b114
**• TensorRT Version:**8.4.0.11-1+cuda11.4
• Issue Type( questions): The output displayed stream with the detection is running very slow with only (10FPS).

Is there a way to increase the FPS of the stream?
I am displaying a 2x2 grid display with 2 sources. This is a school project that my team have been working on for weeks. The model that we are using is trained with TAO using resnet18 network (FasterRCNN).

Here’s the configuration files…

Main executable config file:
[application]
enable-perf-measurement=1
perf-measurement-interval-sec=1
gie-kitti-output-dir=/home/rpdev/FYP/DS_Output/kitti_data
kitti-track-output-dir=/home/rpdev/FYP/DS_Output/kitti_data_tracker

[tiled-display]
enable=1
rows=2
columns=2
#width=1280
#height=720
width=1920
height=1080
gpu-id=0
nvbuf-memory-type=0

[source0]
enable=1
#Type - 1=CameraV4L2 2=URI 3=MultiURI
type=3
num-sources=2
uri=file:///opt/nvidia/deepstream/deepstream/samples/streams/ddstreams/mp4/testingvid1.mp4
gpu-id=0
drop-frame-interval=2

[source1]
enable=1
#Type - 1=CameraV4L2 2=URI 3=MultiURI
type=3
num-sources=2
uri=file:///opt/nvidia/deepstream/deepstream/samples/streams/ddstreams/mp4/testingvid3.mp4
gpu-id=0
drop-frame-interval=2

[streammux]
gpu-id=0
batch-size=1
#batched-push-timeout=40000
batched-push-timeout=0
width=1280
height=960
nvbuf-memory-type=0

[sink0]
enable=1
#Type - 1=FakeSink 2=EglSink 3=File
type=2
sync=0
qos=0
source-id=0
gpu-id=0

[osd]
enable=1
gpu-id=0
border-width=3
text-size=15
text-color=1;1;1;1;
text-bg-color=0.3;0.3;0.3;1
font=Arial
process-mode=2

[primary-gie]
enable=1
gpu-id=0
model-engine-file=/opt/nvidia/deepstream/deepstream/samples/models/Drowning_Detector/frcnn_kitti_resnet18_540_960_retrain_int8.etlt_b1_gpu0_int8.engine
batch-size=1
#Required by the app for OSD, not a plugin property
bbox-border-color0=1;0;0;1
bbox-border-color1=0;1;1;1
#bbox-border-color1=1.5;1;0.2;1
bbox-border-color2=0;0;1;1
bbox-border-color3=0;1;0;1
gie-unique-id=1
config-file=config_infer_primary_frcnn_jetson.txt

[sink1]
enable=1
type=3
#1=mp4 2=mkv
container=1
#1=h264 2=h265 3=mpeg4
codec=1
enc-type=0
sync=0
bitrate=6000000
#H264 Profile - 0=Baseline 2=Main 4=High
#H265 Profile - 0=Main 1=Main10
profile=0
output-file=/home/rpdev/FYP/DS_Output/recordings/out.mp4
source-id=0

[tracker]
enable=1
tracker-width=960
tracker-height=544
ll-lib-file=/opt/nvidia/deepstream/deepstream/lib/libnvds_nvmultiobjecttracker.so
ll-config-file=…/deepstream-app/config_tracker_NvDCF_perf.yml
enable-batch-process=1
enable-past-frame=1
display-tracking-id=1

[tests]
file-loop=1

Reference config file:
[property]
gpu-id=0
net-scale-factor=1.0
offsets=103.939;116.779;123.68
model-color-format=1
labelfile-path=/opt/nvidia/deepstream/deepstream/samples/models/Drowning_Detector/labels.txt
tlt-encoded-model=/home/rpdev/FYP/DDV3/frcnn_kitti_resnet18_540_960_retrain_int8.etlt
int8-calib-file=/home/rpdev/FVP/DDV3/cal.bin
tlt-model-key=dHF0MTlnYWltNzVjb3EycmczZ290MDd1NW06NzUxNjhiY2YtZmM4Yi00YWJjLTgwZGMtMWRlZjQ4YTkyMjZm
infer-dims=3;544;960
uff-input-order=0
uff-input-blob-name=input_image
batch-size=1
network-mode=1
num-detected-classes=4
interval=0
gie-unique-id=1
is-classifier=0
#network-type=0
output-blob-names=NMS
parse-bbox-func-name=NvDsInferParseCustomNMSTLT
custom-lib-path=/opt/nvidia/deepstream/deepstream/lib/libnvds_infercustomparser.so

[class-attrs-all]
pre-cluster-threshold=0.6
roi-top-offset=0
roi-bottom-offset=0
detected-min-w=0
detected-min-h=0
detected-max-w=0
detected-max-h=0

There is no update from you for a period, assuming this is not an issue anymore.
Hence we are closing this topic. If need further support, please open a new one.
Thanks

Can you refer to the trouble shooting document: Troubleshooting — DeepStream 6.1 Release documentation?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.