How do I know what version of L4T my Jetson TK1 is running?

Hi All,

I have a Jetson that was configured by somebody else to run ROS (Robot Operating System). I would like to figure out which version of L4T it is running. I can’t find any way to see the L4T version.

A colleague recalls installing r21.3. uname -r shows 3.10.24-grinch-19.3.8. Another colleague installed that. I guess that is a mismatch already isn’t it? And I don’t think I can flash the new update without losing the current configuration with ROS, am I right?

Best,
Koen

1 Like

I think you can check the Linux for Tegra version with:

cat /etc/nv_tegra_release

The kernel version “3.10.24-grinch-19.3.8” means that you are running the Grinch kernel 19.3.8 based on the Linux for Tegra kernel 19.3 but it doesn’t yet mean that the user space would also be 19.3.

Unfortunately there’s no official way to upgrade the whole system, so to upgrade you would need to reflash the latest Linux for Tegra version and then install all the ROS stuff back.

Maybe yet better way:

head -n 1 /etc/nv_tegra_release

to have only the related stuffed shown.

This is pretty generic. Using the method above it says I have version R21.
At the time of this post there are 5 different releases of R21 since November 2014!

How do I find the FULL version of L4T? Is it R21.1? R21.2? R21.5?
There is a lot of value in that little decimal point.

How do I get it?

The output for “head -n 1 /etc/nv_tegra_release” is of this format:

# <b>R21</b> (release), <b>REVISION: 5.0</b>, GCID: 7273100, BOARD: ardbeg, EABI: hard, DATE: Wed Jun  8 04:19:09 UTC 2016

“R21” is major version, “REVISION: 5.0” is minor version…L4T R21.5.

Arrrrgh, why do they show it that way? I guess they never hear of the K.I.S.S. method. Thanks for the info!

1 Like

In the case described first, the board does not connect to the network (so I can’t ssh to it).

But I made more experiments:

  • (described in first post) 4K TV LG OLED 55" (newer): shows beginning of boot process in 4K but hangs (sometimes more things happen, which usually end up in errors and reboot)
  • On another 4K TV (Samsung LCD, 48"), the system boots in 4K and everything seems to work.
  • On another 4K TV (LG OLED 55", but older than first one): the system boots fine in 1080p, then switching to 4K from the desktop works fine.

So, it seems I could make it work in any case, but I need to:

  • Force default resolution to 1080p if possible (even if screen supports 2160p), at a lower HDMI clock
  • Change resolution from a script or a program (how?)

Also, it seems I do have the latest version:

# R27 (release), REVISION: 1.0, GCID: 8566447, BOARD: t186ref, EABI: aarch64, DATE: Thu Mar  2 05:14:54 UTC 2017

[EDIT: sorry, wrong thread… :( ]

That’s R27.1, which runs only on the TX2 (this is the TK1 forum). You will probably want to repost your question here:
https://devtalk.nvidia.com/default/board/188/jetson-tx2/

Meanwhile, you may wish to add this to “/etc/X11/xorg.conf” (in Section “Device”) for increased logging of mode issues (then look at “/var/log/Xorg.0.log”):

Option      "ModeDebug"

Can someone clarify: we should literary type “head -n 1 /etc/nv_tegra_release” to get version of L4T ?
Because, it is not working for me.

Assuming you’re typing this in a terminal on Jetson, either head is not working on your system, either you don’t have file /etc/nv_tegra_release.

What gives ? :

head --version
ls -al /etc/nv_tegra_release

FYI, the file “/etc/nv_tegra_release” is installed from the command line tool “apply_binaries.sh” from the host PC prior to flash. JetPack does this automatically. If the file is completely missing then flash was incorrect and you’ll be missing a lot of direct hardware access (e.g., you might have the Nouveau video driver which is software only).

It worked but with this command: ““head -1 /etc/nv_tegra_release””