How do I recover Jetson Nano Network-Manager after purging it?

I purged the Network-Manager from the Jetson Nano, I have tried running these options with no success:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install network-manager

err 1: failed to resolve "

I can’t use man or man-db because they don’t work and when I run the “unminimize” command it does nothing to help, there is also no interfaces file in the /etc/network directory.

Reason why i purged it:
it was standard practice to delete a program that is giving you problems so I tried to remove it and download it again.


Welcome to the NVIDIA Developer forums. This topic belongs in the Jetson forums. I have moved it over for you.


Where can I find the jetson forums?

They are located under Autonomous Machines.

Latest Autonomous Machines/Jetson & Embedded Systems topics - NVIDIA Developer Forums

If there is nothing important on the system, then I would suggest just flashing again. NetworkManager has its fingers in a lot of different configurations. The one thing I would consider other than that is to first list some services and their status. This is what a TX2 has:

# systemctl list-units | grep -i network
boinc-client.service                                                                loaded active     running         Berkeley Open Infrastructure Network Computing Client                        
networkd-dispatcher.service                                                         loaded active     running         Dispatcher daemon for systemd-networkd                                       
networking.service                                                                  loaded active     exited          Raise network interfaces                                                     
NetworkManager.service                                                              loaded active     running         Network Manager                                                              
systemd-resolved.service                                                            loaded active     running         Network Name Resolution                                                      
systemd-timesyncd.service                                                           loaded active     running         Network Time Synchronization                                                 
ubuntu-fan.service                                                                  loaded active     exited          Ubuntu FAN network setup                                                                                                           loaded active     active          Network is Online                                                                                                                     loaded active     active          Network (Pre)                                                                                                                             loaded active     active          Network                                                                                                                                loaded active     active          Host and Network Name Lookups      

Of all of these, what do you see? Especially, what do you see for “networking.service” and “NetworkManager.service”? These services need to be active for the software to function (even if configuration is correct it won’t work should the service not be told to run).

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.