How do I use the occupied pins in nano?

I use customer products SOM Nano module with my own carrier board,
L4T is R32.2.1,sources and rootfs are all the same.

I’m not using camera,so i extended some camera IO for other usage.
When i use the default tegra210-p3448-0002-p3449-0000-b00.dts, some dts node’status is “okay”.
And I get info by cmd “cat /sys/kernel/debug/gpio”:

gpiochip0: GPIOs 0-255, parent: platform/6000d000.gpio, tegra-gpio:
 gpio-2   (                    |pcie_wake           ) in  hi
 gpio-6   (                    |system-suspend-gpio ) out hi
 gpio-64  (                    |i2c-mux-gpio        ) out hi
 gpio-65  (                    |?                   ) out hi
 gpio-151 (                    |cam_reset_gpio      ) out lo
 gpio-152 (                    |cam_reset_gpio      ) out lo
 gpio-189 (                    |Power               ) in  hi IRQ
 gpio-190 (                    |Forcerecovery       ) in  hi IRQ
 gpio-202 (                    |pwm-fan-tach        ) in  hi IRQ
 gpio-203 (                    |vdd-3v3-sd          ) out lo
 gpio-225 (                    |hdmi2.0_hpd         ) in  hi IRQ
 gpio-228 (                    |extcon:extcon@1     ) in  lo IRQ
 gpio-231 (                    |?                   ) out hi

gpiochip1: GPIOs 504-511, parent: platform/max77620-gpio, max77620-gpio, can sleep:
 gpio-505 (                    |spmic-default-output) out hi
 gpio-507 (                    |vdd-3v3-sys         ) out hi
 gpio-510 (                    |enable              ) out lo
 gpio-511 (                    |avdd-io-edp-1v05    ) out lo

“gpio-64” -> “i2c-mux-gpio”,“gpio-151” -> “cam_reset_gpio” are used.
“gpio-65” is a led which is not my usage.

I can confirm that the following node has been disabled.

tegra-camera-platform {
		compatible = "nvidia, tegra-camera-platform";
		status = "disabled";
        };
	cam_i2cmux {
		compatible = "i2c-mux-gpio";
		#address-cells = <0x1>;
		#size-cells = <0x0>;
		mux-gpios = <0x56 0x40 0x0>;
		i2c-parent = <0xa8>;
		status = "disabled";
        };
        camera-control-output-low {
			gpio-hog;
			output-low;
			gpios = <0x97 0x0 0x98 0x0>;
			label = "cam1-pwdn", "cam2-pwdn";
			status = "disabled";
        };
	leds {
		compatible = "gpio-leds";
		status = "disabled";
		linux,phandle = <0xc7>;
		phandle = <0xc7>;

		pwr {
			gpios = <0x56 0x41 0x0>;
			default-state = "on";
			linux,default-trigger = "system-throttle";
		};
	};

I want to use gpio-64,gpio-65,gpio-151,gpio-152 as general gpios, and I do not want to modify the common dts “tegra210-porg-plugin-manager.dtsi”.
How to implement the above modification by just modifying the top dts file “tegra210-p3448-0002-p3449-0000-b00.dts” ???

Can you try to remove the below from the tegra210-porg-p3448-common.dtsi to try.
Also double confirm the status at /proc/device-tree/tegra-camera-platform/cam_i2cmux/

#include "porg-plugin-manager/tegra210-porg-plugin-manager.dtsi"

Hi,ShaneCCC

There are many other config in file “porg-plugin-manager/tegra210-porg-plugin-manager.dtsi”, if i remove the tegra210-porg-plugin-manager.dtsi from the tegra210-porg-p3448-common.dtsi, it will definitely affect other functions.

dmesg | grep plugin-manager
[    0.383419] Initializing plugin-manager
[    0.383754] node /plugin-manager/fragement@0 match with board >=3448-0002-100
[    0.384311] node /plugin-manager/fragment@1 match with board >=3448-0002-101
[    0.384814] node /plugin-manager/fragment@3 match with board >=3448-0002-100
[    0.385551] node /plugin-manager/fragement@6 match with odm-data enable-tegra-wdt
[    0.385996] node /plugin-manager/fragement@8 match with odm-data enable-tegra-wdt
[    0.386632] node /plugin-manager/fragement@10 match with board >=3448-0002-300
fragement@10 {
			ids = ">=3448-0000-300", ">=3448-0002-300";
			override@0 {
				target = <&{/pcie@1003000/pci@2,0}>;
				_overlay_ {
					nvidia,plat-gpios = <&gpio TEGRA_GPIO(CC, 7) GPIO_ACTIVE_HIGH>;
				};
			};
			override@1 {
				target = <&sdhci2>;
				_overlay_ {
					vmmc-supply = <&max77620_ldo6>;
					no-sdio;
					no-mmc;
					sd-uhs-sdr104;
					sd-uhs-sdr50;
					sd-uhs-sdr25;
					sd-uhs-sdr12;
				};
			};
			override@2 {
				target = <&throttle_oc1>;
				_overlay_ {
					nvidia,priority = <50>;
					nvidia,polarity-active-low = <1>;
					nvidia,count-threshold = <1>;
					nvidia,alarm-filter = <5100000>;
					nvidia,alarm-period = <0>;
					nvidia,cpu-throt-percent = <75>;
					nvidia,gpu-throt-level =
						<TEGRA_SOCTHERM_THROT_LEVEL_HIGH>;
				};
			};
			override@3 {
				target = <&{/leds}>;
				_overlay_ {
					status = "okay";
				};
			};

plugin-manager match fragement@0,fragment@1,fragment@3,fragement@6,fragement@8,fragement@10.
The cam_i2cmux is related at fragement@10,but it also contains pcie, sdhci2 and throttle_oc1.
It’s hard for me to remove the tegra210-porg-plugin-manager.dtsi,is there a better way ?

Then there’s no other way to remove below from the tegra210-porg-plugin-manager.dtsi

/* gpio based i2c mux */
 			override@29 {
 				target = <&{/cam_i2cmux}>;
 				_overlay_ {
 					status = "okay";
 				};
 			};