How does nvarguscamerasrc use gamma

How can I make sure my system supports gamma?
I noticed that gst-launch-1.0 has gamma plugin, how to use it with nvarguscamerasrc? I have the following command:


GST_DEBUG_DUMP_DOT_DIR=/media/Data/log gst-launch-1.0 nvcompositor name=comp sink_0::xpos=0 sink_0::ypos=0 sink_0::width=960 sink_0::height=540         sink_1::xpos=960 sink_1::ypos=0 sink_1::width=960 sink_1::height=540         sink_2::xpos=0 sink_2::ypos=540 sink_2::width=960 sink_2::height=540         sink_3::xpos=960 sink_3::ypos=540 sink_3::width=960 sink_3::height=540         ! nvvidconv ! 'video/x-raw(memory:NVMM),width=1920,height=1080,format=NV12,framerate=10/1' ! nvv4l2h264enc bitrate=4000000 ! h264parse ! flvmux ! rtmpsink blocksize=24834048  location='rtmp://127.0.0.1/live/mux4'         nvarguscamerasrc sensor-id=0 wbmode=0 ee-mode=0 saturation=0 blocksize=99336192 ! 'video/x-raw(memory:NVMM), width=(int)4128, height=(int)3008,format=(string)NV12, framerate=(fraction)10/1' ! tee name=cam0 !        queue !  nvvidconv  interpolation-method=5  ! "video/x-raw(memory:NVMM), width=2064, height=1504, format=(string)NV12" !  nvvidconv  ! "video/x-raw" !  multifilesink max-file-size=1862553600  next-file=4 blocksize=4096 location=cam0_%04d.nv12 -e cam0. ! queue ! comp.sink_0 cam0. ! queue !   nvvidconv ! 'video/x-raw(memory:NVMM),width=3840,height=2160,format=NV12,framerate=10/1' ! nvv4l2h265enc bitrate=20000000 capture-io-mode=2 maxperf-enable=true ! h265parse ! mp4mux ! filesink location=cam-0.mp4         nvarguscamerasrc sensor-id=1 wbmode=0 ee-mode=0 saturation=0 blocksize=99336192 ! 'video/x-raw(memory:NVMM), width=(int)4128, height=(int)3008,format=(string)NV12, framerate=(fraction)10/1' ! tee name=cam1 !         queue !  nvvidconv  interpolation-method=5  ! "video/x-raw(memory:NVMM), width=2064, height=1504, format=(string)NV12" !  nvvidconv  ! "video/x-raw" !  multifilesink max-file-size=1862553600  next-file=4 blocksize=4096 location=cam1_%04d.nv12 -e cam1. ! queue ! comp.sink_1  cam1. ! queue !   nvvidconv ! 'video/x-raw(memory:NVMM),width=3840,height=2160,format=NV12,framerate=10/1'  ! nvv4l2h265enc bitrate=20000000 capture-io-mode=2 maxperf-enable=true ! h265parse ! mp4mux ! filesink location=cam-1.mp4         nvarguscamerasrc sensor-id=2 wbmode=0 ee-mode=0 saturation=0 blocksize=99336192 ! 'video/x-raw(memory:NVMM), width=(int)4128, height=(int)3008,format=(string)NV12, framerate=(fraction)10/1' ! tee name=cam2 !        queue !  nvvidconv  interpolation-method=5  ! "video/x-raw(memory:NVMM), width=2064, height=1504, format=(string)NV12" !  nvvidconv  ! "video/x-raw" !  multifilesink max-file-size=1862553600  next-file=4 blocksize=4096 location=cam2_%04d.nv12 -e cam2. ! queue ! comp.sink_2  cam2. ! queue !   nvvidconv ! 'video/x-raw(memory:NVMM),width=3840,height=2160,format=NV12,framerate=10/1' ! nvv4l2h265enc bitrate=20000000 capture-io-mode=2 maxperf-enable=true ! h265parse ! mp4mux ! filesink location=cam-2.mp4         nvarguscamerasrc sensor-id=3 wbmode=0 ee-mode=0 saturation=0 blocksize=99336192 ! 'video/x-raw(memory:NVMM), width=(int)4128, height=(int)3008,format=(string)NV12, framerate=(fraction)10/1' ! tee name=cam3 !        queue !  nvvidconv  interpolation-method=5  ! "video/x-raw(memory:NVMM), width=2064, height=1504, format=(string)NV12" !  nvvidconv  ! "video/x-raw" !  multifilesink max-file-size=1862553600  next-file=4 blocksize=4096 location=cam3_%04d.nv12 -e cam3. ! queue ! comp.sink_3  cam3. ! queue !   nvvidconv ! 'video/x-raw(memory:NVMM),width=3840,height=2160,format=NV12,framerate=10/1'  ! nvv4l2h265enc bitrate=20000000 capture-io-mode=2 maxperf-enable=true ! h265parse ! mp4mux ! filesink location=cam-3.mp4

Sorry to tell nvarguscamerasrc don’t have gamma configure.

Thanks

What do I do if I want to use gamma?

Maybe try the tonemap by Argus APP.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.