How much cameras AXG Xavier can processed?

I think it’s wrong because I use another adapter board this.
So, I’m starting to solve the SIGSEGV problem. It should help me to start using jetpack 4.4.
Great thanks for helping me!

Hi. Kuskov.

Yes. You are right. You need to modify the device tree in the driver to make it work. Since the hardware design of Connect Tech adapter board is different with us. You can ask Connect Tech team to help you about this.

Happy New Year!

Hi Kuskov! Have you contacted our Tech Support team? If you fill out our Support Form, our Tech Team will help you work through this. You can find the form here: Customer Support Form - Connect Tech Inc.
Thanks, Jacki

@jross @ShaneCCC @KevinGong
Hello everyone! I install Jetpack 4.4 with drivers for JCB004 for imx390 cameras, but it still not work.
I’m started stream (gst-launch, argus-camera, nvgstsrc) and after few minutes stream freezes and jetson reboots.
gst-launch give me this message:

And on the other jetson with same software and hardware it works. I don’t know why.

What I’m to do:

After starting gst-launch i try to inspect nvargus-daemon:

I add queue into gst-launch and it stop reboots, but it freeze camera streams.
gst-launch-1.0 nvarguscamerasrc sensor-id=0 ! ‘video/x-raw(memory:NVMM), width=(int)1920, height=(int)1080, framerate=30/1’ ! queue ! nvvidconv flip-method=0 ! ‘video/x-raw, format=(string)I420’ ! queue max-size-bytes=0 max-size-time=0 ! xvimagesink -e

I’m see what when it freezes one cpu core loads 100%.

And it happens when system was started (when gstreamer not launched yet).

Hi. Kuskov.
So you are using the driver from CONNECTTECH. Right?

Did you turn on the fan as well? I haven’t met frozen issue on AGX Xavier. Usually Argus tool may cost more CPU percentage. But the video shouldn’t freeze when you use Gstreamer.

@jross. Hi. Jacki. Can you reproduce this issue on your side?

Thanks. Kevin.

Yes. Drivers from Connecttech.
I turn on jetson_clocks too. In Jetpack 4.4 its not turn fan on maximum speed right away, depends from temperature.

More unusual as I think what on another jetson with same gmsl board, cameras and installation steps it works well.

One more feature:
I’m try to install camera_argus and it have segmentation fault when started on system when all works normal. I applied this solution and argus_camera was started.
But in the system where streams freezes argus_camera works without other manipulation, just after installation argus_camera example.

I want to try on other Jetson’s on this week and write about results.

Hi Kuskov,

Please let us know if you see issues with the proposed setup, as we have not seen any issues operating in this environment. When you mention other Jetsons are you referring to other AGX Xavier modules? What is the Power supply you are using for the system during testing?


-Rob Callaghan

Hi Rob!
Yes? I mean another AGX Xavier boards. Yesterday on another board there were also freezes and the argus camera crashed, but the system did not reboot.
I use standard power supply of Xavier dev kit. For JCB004 - 12v 2A power supply

I try install os on other AGX Xavier boards, they work ok. But i run argus camera on one another for writing video and it gives me some errors and same behavior (1 cpu core loads on 100%, and stream freezes).
Errors in files:
err.txt (3.0 KB) err2.txt (3.7 KB)

@ShaneCCC @kayccc I think what problem with Xorg. When I displaying streams its load 1 core on 100%. When I’m not displaying it works ok.
What can be done about it? Maybe not load display when system is started?

What’s the output size?
Could you try ./argus_camera --outputsize=640x480

I’m try with 2 320x480 windows via gstreamer nvarguscamerasrc - it reboot.
I’m so try without displaying. Its work 5 hours and reboot.
Now i will try argus_camera --outputsize=640x480 and waiting some results

problem looks same as: AGX Xavier (CPU near 100% load) self reboot problem
but not depends from network connection in my case

I would suggest to file new topic as the issue didn’t match original title describe.

I create new topic: