How set OS for CUDA?( Ubuntu)


I have some source about Executing time Difference between CPU and CPU+GPU…

OS : ubuntu 9.04 32bit, CPU : Intel E6200?, GPU : 9800GT

So, I Have some test…

  1. tty Mode(Is it call Virtual Console??? ) + gdm STOP

  2. tty Mode + gdm Not stop…

That’s Large Differencel;;;

If. I have test using CUDA;;

How setting my PC… OS???

On…Gnome / On tty Mode??

Help me

Are you asking why CUDA programs stop running unexpectedly when you run them with gdm running?

If you are, the reason is that the display driver includes a watchdog timer which will not allow CUDA programs to run for more than 5 seconds at a time. You have to choices to work around this: either reduce the running time of each kernel (make the code faster or reduce the amount of work per kernel launch and run the kernel more times), or use a card without a display driver attached (ie. no gdm, which you already found by yourself).

If you are asking about something else, then perhaps try asking your question in a slightly easier to understand manner, because it is extremely cryptic and hard to follow.

thank you… and sorry…

I have a question. What is better setting to run CUDA;

I tests two Setting. Mentioned above…

Object : Executing time of Algorithm

So, Need’s more suitable to run CUDA

I think that Console Mode(GDM stopping)is most setting… at First

so, Before Test.

Ctrl + Alt + F2 (Consol Mode… Virtual?)

$ sudo invoke-rc.d gdm stop

But,Gained result for Executing time of Algorithm On Two setting

TTY mode running GDM is better than stopped GDM

Not many of test…I want to know that running GDM is more suitable than stopped GDM to run CUDA

;; Ah… Test is not Image problem…Work Computing Data, Memory Transfer, Record file.

Additionary… What is Killed processor to run CUDA

ex ) I have kill processor compiz.real , update-notifier

Your post is still very difficult to interpret. I would actually suggest you write in your native language and run it through something like google translate.

If I understand part of your question correctly, you want to know if you should have X11/gdm running in the background? I would recommend closing it.

If you want to have X11 running, use a second graphics card.

about that… on my laptop (one gpu obviously, single SM) I have this issue that my cuda programs won’t give the correct results (they do execute but the output is whatever…). This problem is fixed if I use a tty to execute (that is, temporarily take the weight of the graphics off of the GPU).

the odd about this is that the sample nvidia programs that include graphics as well (mine don’t) run just fine, executed from gnome, with no complains or obvious performance degradation…

any ideas?

ok, I know this thread is old, but I still thought I should give it a try

thanks in advance for any answers!