How should I install RASA on Jetson Nano?

I am trying to install RASA on Jetson Nano.
However, I failed to install the dependencies.
The install requirements of RASA:
install_requires = [
“requests>=2.20”,
“boto3~=1.9”,
“matplotlib~=3.0”,
“attrs>=18”,
“jsonpickle~=1.1”,
“redis~=3.3.5”,
“pymongo[tls,srv]~=3.8”,
“numpy~=1.16”,
“scipy~=1.2”,
“tensorflow~=1.14.0”,
# absl is a tensorflow dependency, but produces double logging before 0.8
# should be removed once tensorflow requires absl > 0.8 on its own
“absl-py>=0.8.0”,
# setuptools comes from tensorboard requirement:
# https://github.com/tensorflow/tensorboard/blob/1.14/tensorboard/pip_package/setup.py#L33
“setuptools >= 41.0.0”,
“tensorflow-probability~=0.7.0”,
“tensor2tensor~=1.14.0”,
“apscheduler~=3.0”,
“tqdm~=4.0”,
“networkx~=2.3”,
“fbmessenger~=6.0”,
“pykwalify~=1.7.0”,
“coloredlogs~=10.0”,
“scikit-learn~=0.20.2”,
“ruamel.yaml~=0.15.0”,
“scikit-learn~=0.20.0”,
“slackclient~=1.3”,
“python-telegram-bot~=11.0”,
“twilio~=6.0”,
“webexteamssdk~=1.1”,
“mattermostwrapper~=2.0”,
“rocketchat_API~=0.6.0”,
“colorhash~=1.0”,
“pika~=1.0.0”,
“jsonschema~=2.6”,
“packaging~=19.0”,
“gevent~=1.4”,
“pytz~=2019.1”,
“python-dateutil~=2.8”,
“rasa-sdk~=1.4.0”,
“colorclass~=2.2”,
“terminaltables~=3.1”,
“sanic~=19.6”,
“sanic-cors==0.9.9.post1”,
“sanic-jwt~=1.3”,
“aiohttp~=3.5”,
“questionary>=1.1.0”,
“python-socketio>=4.3.1”,
# the below can be unpinned when python-socketio pins >=3.9.3
“python-engineio>=3.9.3”,
“pydot~=1.4”,
“async_generator~=1.10”,
“SQLAlchemy~=1.3.0”,
“kafka-python~=1.4”,
“sklearn-crfsuite~=0.3.6”,
“PyJWT~=1.7”,
# remove when tensorflow@1.15.x or a pre-release patch is released
# https://github.com/tensorflow/tensorflow/issues/32319
“gast==0.2.2”,
]

I failed to install scipy 1.2 and tensor2tensor 1.14.
The updated version of scipy I could install is 0.19.1.

Does anybody have installed RASA successfully on Jetson nano?
Could you share your experience?

Hi,

Are you using python3?

We can install scipy and tensor2tensor with the following command:

sudo pip3 install scipy==1.2
sudo pip3 install tensor2tensor==1.14

Would you mind to give it a try?
Thanks.

Thanks for your advice.

After installation of the following dependencies, scipy 1.2 is successfully installed.
$ sudo apt-get install libblas-dev liblapack-dev libatlas-base-dev gfortran

https://devtalk.nvidia.com/default/topic/1042976/jetson-tx2/pip-install-something-but-error-with-could-not-find-a-satisfies-version/

However, I still have problem in installation of tensor2tensor 1.14.0
The error message is:
Could not find a version that satisfies the requirement opencv-python (from tensor2tensor==1.14.0) (from versions: )
No matching distribution found for opencv-python (from tensor2tensor==1.14.0)

Does anybody have idea about the installation failure of tensor2tensor==1.14.0 (or opencv-python) on Jetson Nano?

After skipping the installation of tensor2tensor, I could successfully install RASA 1.5.0a1 on Jetson Nano, although without tensor2tensor.

Hi,

Try this:

$ sudo pip3 install tensor2tensor==1.14 --no-dependencies

Thanks

Hey which version of rasa are you currently using on Jetson nano? I would really appreciate some help.