How the set backwardCompatibilityCheckMode to be "disabled " permanately?

I think it is really stupid when you run isaacsim by the python scripts, and the backwardCompatibility checker Pop-ups and you need to click to close it every every time ! . I can set backwardCompatibilityCheckMode disabled in edit->preference->physics .

But when you run isaac sim by python scripts again , it comes back .
By the way the modify content in preference takes no effect in python script running isaacsim . Maybe you can do something to make it easier for users.

I try to config in omni.isaac.sim.python.kit and user.config.json , but takes no effect too.
Thank you very much if you could help me !

Hi @fzg7919

You can run the script or launch Isaac Sim from the command line with the following argument to disable the physics backward compatibility check


Thank you so much !
And I have found the way to save preference changes automatically - just set "[]
persistent = true " in omni.isaac.sim.python.kit file .

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.