How to access/manipulate Always On (AON) GPIOs from the SPE/AON processor?

Hi Jachen,

Getting the below compilation errors (download SPE firmware by

Followed this link to resolve error but still I see only one error: Xavier / TX2 SPE (Cortex-R5) Freeertos Compiling Process Record - Programmer Sought

yyappan@ayyappan:~/nvidia/SPE/l4t-rt/rt-aux-cpu-demo$ make TARGET=t19x
mkdir -p /home/ayyappan/nvidia/SPE/l4t-rt/rt-aux-cpu-demo/out/t19x
CC clk.c
CC init_padctrl.c
CC spe-clk.c
CC spe-pm-sequencer.c
/home/ayyappan/nvidia/SPE/l4t-rt/rt-aux-cpu-demo/soc/t19x/src/spe-pm-sequencer.c:63:34: error: redundant redeclaration of ‘tegra_hsp_id_top0’ [-Werror=redundant-decls]
63 | extern const struct tegra_hsp_id tegra_hsp_id_top0;
| ^~~~~~~~~~~~~~~~~
In file included from /home/ayyappan/nvidia/SPE/l4t-rt/rt-aux-cpu-demo/soc/t19x/src/spe-pm-sequencer.c:46:
/home/ayyappan/nvidia/SPE/l4t-rt/freertos-common-t19x/include-soc/t194-aon/hsp-tegra-hw.h:36:34: note: previous declaration of ‘tegra_hsp_id_top0’ was here
36 | extern const struct tegra_hsp_id tegra_hsp_id_top0;
| ^~~~~~~~~~~~~~~~~
cc1: all warnings being treated as errors
make: *** [Makefile:370: /home/ayyappan/nvidia/SPE/l4t-rt/rt-aux-cpu-demo/out/t19x/spe-pm-sequencer.o] Error 1

Ayyappan R

Hi Jachen,

Could you guys support the AON feature in the latest version. Going to older version gives lots of issues in Xavier NX. Thinking of using other platform in this case

Ayyappan R

Hello, ayyappan.rathinam:
Can you provide more details about ‘Going to older version gives lots of issues in Xavier NX’? Do you mean SPE firmware issue or BSP issue?
BSP 32.5, together with SPE firmware are verified and there should not be any issue, with guides in SPE packages.

The main issue for latest rel-35 SPE support is that Xavier NX support is removed. So there’s no guide for Xavier NX setting update in rel-35 SPE firmware.

If you can use rel-32, we can proceed for SPE building issue.

(In addition, since this topic is solved, it’s better to file a new thread for further discussion.)


OK. First will resolve the SPE compilation error.

Today I took the default BSP 32.5 and tried flashing it in my NX borad. But it failed. Will post you the logs soon. Before that SPE compilations should be resolved. Please help in that compilation.

and yes we can open one new thread if you want.

Please help to open a new thread and paste the URL here. We can track in new thread.


Below is the thread:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.