How to accurately set nvbuf-memory-type when using the plugin Gst-nvvideoconvert?

When using the Gst-nvvideoconvert plugin, I see nvbuf-memory-type is set to 1, inside deepstream_opencv_test in a6000 and AGX Xavier. Strangely enough, they both work correctly.
But what I see in the help documentation is that
Type of memory to be allocated. for dGPU:
0 (nvbuf-mem-default): Default memory, cuda-device
1 (nvbuf-mem-cuda-pinned): Pinned/Host CUDA memory
2 (nvbuf-mem-cuda-device) Device CUDA memory
3 (nvbuf-mem-cuda-unified): Unified CUDA memory
For Jetson:
0 (nvbuf-mem-default): Default memory, surface array
4 (nvbuf-mem-surface-array): Surface array memory
So I’m more clear on how strictly this setting needs to be followed?

The complet code is
if(!prop.integrated) {
/* Set properties of the nvvideoconvert element
* requires unified cuda memory for opencv blurring on CPU
g_object_set (G_OBJECT (nvvidconv), "nvbuf-memory-type", 1, NULL);

So the memory type is not 1 with Jetson.

1, so the default nvbuf-memory-type is “0” in the case on jetson?
2, I have the following error on jetson, I suspect it is the problem of this configuration, I should configure nvbuf-memory-type to “4”?

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
• DeepStream Version
• JetPack Version (valid for Jetson only)
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)

Do you mean deepstream-app does not work on your Jetson? Please provide the versions and reproduce set up.

  • jetson AGX XAVIER
  • CUDA 11.4
  • deepstream6.1

I don’t use deepstream-app, I refer to the source code and build my own pipeline, it runs fine on PC-A6000, but has problems on Jetson platform.

I found a line in the help file of gst-dsexample that says “#supported memory types for blur-objects are 1 and 3”. So it means that I can’t set WITH_OPENCV=1,and then enable blur-objects when I want to configure to 0 or 4 under jetson?

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks

You can use WITH_OPENCV=1 and enable blur-objects with nvdsexample on Jetson. The sample application of /opt/nvidia/deepstream/deepstream/sources/apps/sample_apps/deepstream-opencv-test works well on Jetson.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.